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Chapter

PREFACE
What is Public Safety?
Public safety means programs carried out or promoted for public purposes. This involves, directly or
indirectly, the prevention of, protection from, and/or response to natural or manȬmade events that
could endanger the safety or security of people or property in a given area1. Public safety embraces
an interdisciplinary framework to address these threats and respond to the needs of the general
public.

Using GIS for Public Safety

Considering the spatial context of activities and events is important because everyone operates in
space. This is a simple idea, but it is often overlooked. Think about it: your activities, legal and illegal,
happen at some location on Earth. Therefore, public safety and individual risk can change with the
geography—whether it’s one side of a street or one side of town.
A Geographic Information System (GIS) is a tool that adds the dimension of geographic analysis to
research and evaluation by providing an interface between data and a map. GIS has proven to be an
ideal platform for the convergence of public safetyȬspecific information in relation to historical
events, natural or manȬmade disasters, vulnerable populations, and critical infrastructure key to a
community’s sustainability. Data and information in different formats from different locations can be
integrated and displayed in GIS. The data can be quickly queried, analyzed, and displayed through a
map. It can then be easily disseminated, understood and acted on.

About this Book

This book focuses on ESRI’s ArcGIS functionality and presents many of the tools and procedures that
are commonly used by public safety researchers and practitioners. It gives simple steps for
descriptive, exploratory, and explanatory mapping tasks and includes concise but meaningful
discussions to let you critically assess and accurately apply the software to your unique specialty.
This provides a solid foundation for advanced spatial thinking and permits you to utilize GIS
technology in your own innovative ways. This book is intended for an introductory audience, but GIS
users at all skill levels will find value in it as a reference manual. “Introductory” does not mean
limited content. Rather, it means that the focus of the book is on the technical (not theoretical) aspect
of GIS mapping.
If you do not already own ArcGIS Desktop, you may download a free trial copy at www.esri.com.
The download includes a full version of the software at the ArcEditor license level and all extensions
discussed herein. If you are a student with a valid ID card, you might also consider purchasing the
software at the discounted educational rate (as much as 80% off the regular price—good deal!).

PC or MAC?

PC is preferred. ArcGIS by ESRI is designed to run on a Microsoft Windows operating system. But
with tools such as Parallels (www.parallels.com) or Boot Camp (part of MAC OS X Snow Leopard;
www.apple.com), IntelȬbased Macintosh computer users can run ArcGIS products. (Just use an
external mouse or learn how to rightȬclick).
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What is GIS?

A geographic information system (GIS) is a computer software application for managing, editing,
analyzing and displaying data which is spatially referenced to the Earth. GIS is a tool with which
data can be layered with base maps that represent the landscape of the area where the data is
associated. Base maps could represent the street network, buildings, census tracts, or local landȬuse
patterns. These data can be represented as individual layers, displayed as separate entities, or be
combined with other layers to be displayed together2.
Imagine GIS as a highȬtech overhead projector from the “old days” that used
transparent plastic sheets and dryȬerase markers as inputs that were then projected
on a wall. If you think of each transparent sheet as a separate map layer, and you
place all of the transparent sheets (map layers) on top of each other, you can see
through all of them atȬonce. In this way, you can see relationships among the data
that overlap in certain areas. Essentially, GIS does this in much more sophisticated
ways.
Visualizing multiple map layers offers a means of exploring relationships among different data
variables. For example, a map that only shows burglary points and absolutely no other data may not
be particularly helpful. But, the burglary data can be layered with base map data that displays the
street network to show where these burglaries were committed. A third layer could display all the
properties across the area (e.g. owner occupied, rented, vacant buildings)3. These three layers might
suggest that burglary incidents are highest on side streets—not major roadways—and in the areas
where there is also a high percentage of vacant properties.

GIS Components4

A GIS has five components: hardware, software, people, data and storage. The bare minimum for
hardware is a computer. GIS hardware requirements might also include peripherals such as a printer,
plotter, or scanner. PDAs or GPS technology may also be used to synchronize data captured in the
field to a central database5. Digital storage drives are also needed to keep large amounts of data.
OffȬtheȬshelf GIS software products possess a wide range of functionality; though, software
extensions can be added for advanced analysis and map production6. Some relevant software
extensions include Spatial Analyst (for ArcGIS) and Spatial Predictive Analysis Crime Extension
(SPACE). Specialist crime mapping software is also available such as GeoDa, School COP, and
CrimeStat. Quantum GIS (QGIS; www.qgis.org) is a user friendly Open Source GIS that runs on
Linux, Unix, Mac OSX, and Windows. It supports numerous vector, raster, and database formats and
functionalities, and it is free to download and use.
Operating a GIS involves bringing together the computer files that contain the data to be used, and
possibly editing them, querying against them, linking them, adding new data and generating a
display for output. A GIS requires trained people to perform these technical skills, as well as to ask
spatial questions and interpret and communicate findings7.
Data must have a geographic reference such as ZIP codes, street addresses, or x,y coordinates that
can be used to link it to a map. Data collected via Excel, Access, Oracle, or any other type of
spreadsheet or database management system has potential for use in a GIS8.

Chapter One: Introduction to Mapping and ArcGIS

Choosing GIS Resources for Your Organization9
People

GIS users need to be technically skilled in specialized computer software and cartography, but
should also be knowledgeable about your organization’s mission and goals in order to conduct
appropriate analyses and communicate findings effectively. You can train inȬhouse staff to perform
technical and conceptual GIS tasks; however, this could require a large investment of time and
money—especially initially. Although this book can be a useful reference for the novice or advanced
GIS user, learning to manage, map, and analyze data with ArcGIS is most effective if done initially
with an experienced instructor in a tutorial or classroom setting. The person designated as the GIS
specialist will likely need to take a collegeȬlevel GIS course or attend specialize training workshops.
ESRI and other GIS software developers also offer free online training videos, tutorials and
workshops to help get you started. In addition to (or in place of) hiring GIS specialists or training
existing staff, there are several other ways to find people to meet your organization’s GIS needs.
Internship opportunities, for example, can benefit both the students and your organization.
Internships usually do not require extensive financial investments, especially if they are unpaid.
Some universities require an internship as part of their curriculum, so the student’s experience at
your organization can be used towards college credit and serve as a critical component of their
academic and professional development. Contests and scholarship opportunities are other ways to
gain fresh perspectives on issues from the most competitive young minds. You may get a variety of
innovative answers to your questions in exchange for a modest award to the winning applicant(s).

Software

Custom: Depending on the needs and resources of your organization, customized webȬbased or
desktop GIS applications might be appropriate. Custom software can be designed with the most
useful and relevant functionality to meet your organization’s needs. This approach might require
additional hardware (such as web servers) and can be expensive to design and maintain, but it is
something to consider if you want a more streamlined GIS that can be used by one or many users
with minimal training. The Cartographic Modeling Lab’s Neighborhood Information System is one
example of a publiclyȬavailable customized mapping application (www.cml.upenn.edu/nis). Many
software developers specialize in custom GIS applications (be sure to check references and see
examples of past work).
OffȬtheȬshelf: There is a variety of offȬtheȬshelf GIS software applications available for managing,
editing, mapping, and analyzing spatial data. Free applications such as Quantum GIS and GRASS
(Geographic Resources Analysis Support System) do not always come with user manuals and may
not be useful for those who do not already have some basic GIS experience. ArcExplorer is a free GIS
viewer by ESRI that includes supporting materials and is intended only to display, query and retrieve
data. A list and brief description of other free GIS software applications is at www.freegis.org.
PolicyMap (www.policymap.com) provides subscribers with webȬbased GIS applications to make
maps, tables and charts using the company’s database or uploaded user data. MapInfo Professional
(www.pbinsight.com) is a WindowsȬbased mapping and geographic analysis application by Pitney
Bowes that has a long history of use in the public safety sector. ArcGIS by ESRI allows for mapping
and advanced spatial analysis of geographic data, and is the focus of this book. Although this book is
written for an ArcGIS user, be sure to consider all software options to meet the visual and analytical
needs of your organization in the most sensible and meaningful way.
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Is GIS Right for You? Guided Worksheet

Instructions: Before you invest time and money into purchasing the components of a GIS and
training people to use it, be sure that it is right for you. Use this worksheet for guidance in answering
if GIS might be a sound investment and a valuable tool for your organization.
What are the needs and goals of your organization?

How might GIS mapping help to achieve your organization’s needs and goals?
Management decisions:
Needs assessment:
Resource allocation:
Research/evaluation:
Predictive modeling:
Strategic planning:
Other:

What spatial questions might you ask that a GIS can help answer?
1.

2.

3.
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Does the data that your agency and its partners maintain include geographic references such as
street addresses or XY coordinates?
Yes

No

If no, how can you begin to collect this information?

If you are considering GIS now or in the future, then you must ensure the integrity and consistency
of your data. The accuracy and standardization of addresses and other variables will contribute to the
overall ease or difficulty with which the data is integrated into a GIS.
Data are essential to mapping. Data collected via Microsoft Excel or Access, Quattro Pro, Oracle, or
any other type of spreadsheet or database management system has potential for use in a GIS because
they can export data in dBASE IV (.dbf) format. “Shapefiles” (.shp) are another compatible data
format.
Do you have access to existing data in these formats?

Yes

No

What other data will you need in addition to the data that is available from your agency or its
current partners? (Check all that apply)
Ŀ Census data
Ŀ Locations of courts
Ŀ Roads
Ŀ Jurisdictional boundaries of particular
Ŀ Neighborhood boundaries
agencies
Ŀ Locations of public assistance agencies
Ŀ State/county boundaries
Ŀ School/political districts
Ŀ Locations of public housing
Ŀ Transportation routes
Ŀ Locations of hospitals and emergency
Ŀ Park and recreation areas
rooms
Ŀ Locations of social/human services
Ŀ Crime incidents
Ŀ Locations of police stations/substations
Ŀ Locations of youth shelters
Ŀ Locations of prisons and jails
Other required data:

Are these additional data feasible to obtain? If yes, from where? If no, why not?

8
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Is GIS Right for you? Guided Worksheet, page 3 of 3

In addition to people and data, GIS requires certain hardware and software components.
Do you have or can you obtain a computer with at least 1GB RAM and 1.6 GHz processor?
Yes

No

OffȬtheȬshelf desktop software products possess the majority of basic GIS functionality. ArcView by
ESRI, for example, retails for approximately $1,500; extensions for advanced analytical capability cost
more. If you are a nonȬprofit organization then you may qualify for a discount.
Is the software affordable to your agency?

Yes

No

People who operate GIS usually require some form of training to perform technical skills, as well as
to ask spatial questions and interpret and communicate findings appropriately.
Are you willing and able to commit personnel and other resources towards training?
Yes

No

If you believe that GIS would be valuable to your agency, but do not want to or cannot afford to
commit time and resources to it now, then you can partner with other people or organizations.
With whom could you partner?
Ŀ
Ŀ
Ŀ

Faculty or students at a college or university
Student interns
Other:

Representing Objects (Features) in a GIS10

Spatial objects, or features, can be represented in three ways on a map: points, lines or polygons.
x
x

x

Points can either be represented as a dot or other symbol. Locations of hospitals, for example,
may be represented with the
symbol rather than a dot.
Lines (also known as polylines) are straightȬline objects connecting two points. A polyline
depicting a curved line (arc) is actually a series of straight segments. Lines can be displayed in a
range of fonts (e.g. continuous or dashed) and in different colors and thicknesses11. Bus routes,
streets, and rivers are usually represented using lines.
A polygon is a closed area represented around its perimeter with a polyline. It exists as a solid
object for the region it covers12. Police beats, counties, states, and ZIP Codes are examples of
polygons.
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Attribute Tables

Descriptive information about GIS features is stored in attribute tables. For example, an attribute
table for point features representing crime incidents could include the crime type, the date of the
crime, the time of the crime and the address of where the crime occurred. There is always one record
in the attribute table that corresponds to each feature on the map. Attribute information can be used
to view, select, analyze, and display features in a variety of ways on a map.
The attribute table and the features are linked together so that when a point, line or polygon is
queried in a map view the attribute data for the object is also selected (as shown below).

Attribute tables in a GIS will always have at least three columns: FID, Shape, and ID. This
information is used to define the feature and the corresponding record in the attribute table so that a
oneȬtoȬone correspondence is maintained between the feature on the map and its attribute record.
Basically, attribute tables act as a key table between map features and additional information about
each feature.
Attribute Tables Support Many Fundamental GIS Operations13, such as:
x Tables organize and manage descriptive data about features.
x Tables are used for statistical summaries of descriptive data.
x Arithmetic and logic operations on rows and columns in tables are used to select features and to
calculate new information for features.
x Tables are used to relate other information with features

DBF Files

Attribute tables are stored in the dBase file format (.dbf). dBase was the first widely used database
management system (DBMS) for microcomputers. dBase gradually lost market share to competitors
because it was slow to transition successfully to Microsoft Windows. Nevertheless, its underlying file
format, the .dbf file, remains widely used in many contemporary applications that need a simple
format to store structured data. The “shapefile” format for ArcGIS uses .dbf files to store feature
attribute data.

9
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Types of GIS Data
Tabular Data

Tabular data is where you store attribute information about map features. ArcMap can only work
with Excel (.xls), commaȬdelineated text (.txt) and dBase (.dbf) files, so you will need to convert your
tables to one of these formats before adding it to ArcMap.

Geographic Data

Shapefiles are the standard format for geographic data in ArcGIS. Shapefiles are made up of three or
more separate files that all need to be located in the same directory in order for ArcMap to recognize
them as parts of a shapefile. NOTE: shapefiles are used for vector GIS data. Raster GIS data are stored in
files that are more similar to images.

Images

ArcGIS allows you to import and export many different types of images. The images you import may
be scanned paper maps, aerial photos, or other pictures that you “hot link” to your map features. You
can export finished maps in ArcMap in a number of formats: EMP, BMP, EPS, TIFF, PDF, JPEG,
CGM, JPEG, PCX, and PNG.

Shapefiles and Vector Data
Vector Data

Vector is the most common model for GIS data used in the social sciences. It uses points, lines, and
polygons to represent map features. Vector data is excellent for representing discrete objects such as
parcels, streets, and administrative boundaries. The vector format is not as good for representing
things that vary continuously over space, such as temperature and elevation.

Shapefiles

Environmental Systems Research Institute (ESRI; the maker of ArcGIS)
created the shapefile format in order to represent vector GIS data. Other GIS
programs will use shapefiles, but geographic files from other GIS programs
must be converted to shapefiles before ArcGIS applications can read them.
As with other formats of geographic data, shapefiles link information about
the location and shape of the map features to their attributes.
Shapefiles are made up of three or more files that need to be stored in the same directory in order for
ArcGIS to recognize them. The most common files that make up shapefiles are:
.shp Ȭ the file that stores the feature geometry (point

, line

, polygon

)

.shx Ȭ the file that stores the index of the feature geometry
stores the attribute information of features. When a shapefile is added as a
.dbf Ȭ the dBASE file
theme to a map view, this file is displayed as a feature table.

Chapter One: Introduction to Mapping and ArcGIS
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.sbn and .sbx Ȭ the files that store the spatial index of the features. These two files may not exist until
you perform themeȬonȬtheme selection, spatial join, or create an index on a themeȇs shape field.
.pjr – the file that stores information about the projection. This will only
exist for shapefiles with defined projections.
The shapefile stores information about the shape of the map features,
describing them in the “shape” field of the attribute table as point, line, or
polygon. It also stores information about the real world location of each
vertex that makes up the map features. Using this information, ArcGIS can
perform spatial analyses.

Raster Data

Raster data use grids made up of regularlyȬsized cells to represent spatially
continuous data. Each cell is assigned real world coordinates and one
attribute value (such as precipitation level or elevation). The user defines the
cell size, allowing for very fine or course raster surfaces. Even when the cell
size is very small, you can see the individual square cells when you zoom in.
Raster grids cells are like pixels on a TV or computer screen. Whereas
shapefileȬbased map layers are oriented toward the depiction and analysis of
discrete objects in space (represented as points, lines, or polygons), raster
grids are oriented more toward the qualities of space itself.
In order to work with raster data in ArcGIS, you need the Spatial Analyst extension. When raster
layers have the same size cells, their values can be added, subtracted, multiplied, divided and
queried using map algebra.
You can add raster data to ArcMap just as you do vector data, using the “Add Data” button. If the
raster data have no spatial information (e.g. a scanned map that has not been georeferenced), ArcMap
will not be able to display it with other map layers. In this case, you may need to “georeference” the
raster data.
ArcGIS saves raster layers in its GRID format. ArcCatalog recognizes GRIDs and other image formats
(including BMP, JPEG, TIFF) as raster layers. Images with no extension (such as “denst8” shown
below) are GRIDs. If you view a GRID outside of ArcCatalog, it will consist of several files within a
directory.
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Introduction to ArcGIS

ArcGIS is a scalable system of GIS software produced by Environmental Systems Research Institute
(ESRI). This system contains three different products: ArcView, ArcEditor, and ArcInfo.
x

ArcView: ArcView is the desktop version meant for a general (nonȬprofessional) audience. It is
the most popular desktop GIS software program.

x

ArcEditor: ArcEditor includes all the functionality of ArcView, adding
the ability to edit features in a multiȬuser geodatabase so that multiȬuser
editing and versioning are possible. ArcEditor also adds the ability to
edit topologically integrated features in a geodatabase.

x

ArcInfo: ArcInfo is ESRI’s professional GIS software. It includes all of the
functionality in ArcView and ArcEditor, and adds some advanced
geoprocessing and data conversion capabilities.

Introduction to ArcView 9

ArcView 9 includes two separate applications: ArcCatalog and ArcMap. Although they are designed
to work together, they run under separate executable files (.exe) so they each have their own icons.
ArcCatalog works sort of like Windows Explorer. It is a place to browse and manage
your data. You can also create and edit metadata in ArcCatalog.

ArcMap is where you actually create maps and analyze spatial data.
ArcToolbox is integrated directly into ArcCatalog and ArcMap. It gives access to advanced
geoprocessing tools, data conversion tools, and much of the ArcInfo functions.

Introduction to ArcCatalog

ArcCatalog is designed to help manage your spatial and nonȬspatial data. Using
ArcCatalog may seem awkward at first, but doing so will develop good GIS
habits, so it is worth the effort.

Connecting to Folder

File > Connect Folder ȬorȬ Click the “Connect to Folder” Button
When you launch ArcCatalog (from the Start menu, go to ArcGIS, then
ArcCatalog, or add a shortcut to your desktop), a list of all the folders and subȬ
folders on your computer will be displayed on the left in the catalog tree. “Connect to folder” allows
you to make a direct connection to the place on your computer where your GIS data are stored. This
is not necessary but will save time. You will use these same shortcuts in ArcMap (and you can
connect to folder from ArcMap, as well). From the file menu, go to “Connect Folder…” or click on the
“Connect To Folder” button (yellow arrow against a globe). Navigate until you find the folder with
your data and click “OK.” Your folder should now be listed under “Catalog” next to an icon.

Chapter One: Introduction to Mapping and ArcGIS
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Seeing File Types

When the contents tab is active, ArcCatalog will indicate the
type of file using icons. Shapefiles, the format for geographic
files in ArcGIS, are made up of three or more separate files. If
you viewed them outside of ArcCatalog (e.g. in Windows
Explorer or through My Computer), you would see all of the
files listed with extensions such as .dbf, .shp, .shx (see example
at right).
In ArcCatalog these various files will appear as a single shapefile.
ArcCatalog also indicates what kind of shapefile: point, line, polygon, or
geocoding service. In the example on the left, the file “hospitals.shp” is
made up of points, “nis_neighborhoods.shp” is made up of polygons,
and “phila_rails.shp” is made up of lines. “phila_streets.mxs” is a
geocoding service. This means that it has been indexed so that you can
use it to geocode addresses. By copying and pasting shapefiles using
ArcCatalog, you insure that you will keep all of the components of a
shapefile together.
Tables that contain no spatial information can also be displayed in
ArcCatalog. The icon changes depending upon the type of table. Images
can also be displayed in ArcCatalog.

Basic Tasks in ArcCatalog
Previewing Files

By making the “preview” tab active, you can look more carefully at files. When the preview dropȬ
down menu at the bottom of the window is set to “geography,” you can see what your geographic
data looks like mapped. You need to view your data in ArcMap in order to make changes to the way
it displays, but this preview in ArcCatalog allows you to look at it quickly. You can also view images
in the preview mode (ArcCatalog may ask you if you want to build pyramids in order to display
these more quickly, which is probably a good idea).
Switch the preview dropȬdown to “table” in order to view the
attributes associated with your geographic features.
In the table preview mode, click on the “options” button to add a
new field or export the table. Right clicking on a column heading
allows you to access a number of other functions such as sort,
freeze/unfreeze column, delete field, and statistics (the statistics
option is only available for numeric fields). You can also access these
functions in ArcMap.
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Checking Properties

RightȬclick the file > Properties
Double click on the file name to bring up the shapefile or
table properties (or by rightȬclicking the file name and
choosing “properties” from the menu). With the fields tab
active, you can identify the data type for each of the columns
in your table. When you click on a column name, the length
of the field will appear below. When you click on the field
name “shape,” several new field properties appear at the
bottom. From the “spatial reference” field, you can see what
datum and projection have been defined (if any). You can
change or add to this information by clicking on the “…”.
From the index tab, you can create attribute or spatial indexes
in order to increase the speed of searching, querying, and
drawing data.

Searching for Map Data

On the “Standard” toolbar, click the “Search” button
With ArcCatalog, you can search for geographic data on disk or across a network. You can search by
name, file type, geographic location, creation date, or by other properties stored in the metadata. On
the Standard toolbar, click the Search button.

The “Search” dialog box opens with the
“Name & location” tab active. The tabs on
the Search dialog box give you different
ways to search for data. On the Name &
location tab, you search by file name or
type. On the Geography tap, you search
by geographic location. On the Date tab,
you search by the date files were last
accessed or by other dates in the
metadata. On the Advanced tab, you
search for keywords or other metadata
text. ArcCatalog gives each search a name
and saves the results to a Search Results folder. It doesnȇt actually copy or move any data into this
folder. Instead, it creates shortcuts, or pointers, to the data it finds.

Introduction to ArcMap

ArcMap is where you create maps and access most of the
ArcGIS functionality. You can access some of the same
functions through ArcCatalog and will need to decide for
yourself which approach works best for you.
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Starting ArcMap

From ArcCatalog, click the “Launch ArcMap” button
From Windows taskbar, Start > ArcGIS > ArcMap
When ArcMap opens, you will be asked if you want to open an empty map, use a template, or open
an existing map. You can prevent this dialog from displaying again by putting a check mark in the
“do not show this dialog again” box.

Customizing the Interface

ArcMap is made up of many different windows
and (dockȬable) toolbars that you can resize and
move around, so don’t be surprised if ArcMap
looks slightly different each time you open it.

Map display,
or Data View
Table of
Contents

The window that lists your map layers is the
table of contents (TOC); the window that shows
your map is the map display, or Data View. You
can close the table of contents by clicking on the
“x” and resize it by holding your cursor over the right edge until your cursor changes to a twoȬ
headed arrow. LeftȬclick and drag the edge to resize this window. To move one of your toolbars, left
click on the end (top or left), hold down, and drag to a new location.

Working with the Table of Contents

The table of contents has “display” and “source” tabs (at the bottom): When the display tab is active,
the table of contents will only list data that can be drawn as a map layer. When the source tab is
active, the table of contents will also show tables along with the path indicating where the data are
stored. Turn on and off a layer by checking and unȬchecking the box next to it. Layers are drawn in
the map display in the order in which they are shown in the table of contents. Map layers listed at the
top will draw on top. To move a layer above or below other layers, left click and hold the mouse
button down, then move the layer.

Data Frames

From ArcMap, Insert > Data Frame
Data frames group map layers in ArcMap’s table of contents. Most of the
time you will only need one data frame in a map document. But if you
need to include more than one map in your layout (including the same
map at a different extent), you will need two or more data frames (Also see
“Creating Extent Rectangles” in Chapter Three).
When you open ArcMap, you will have just one data frame (called
“Layers”) and every map layer you add to your map document becomes
part of this frame. To add new data (e.g. shapefiles) to a particular data
frame, right click on its name and go to “Add Data” or highlight its name
and use the Add Data button

(or, Insert > Add Data).
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If you want to move a layer to a different data frame once it is in ArcMap,
rightȬclick the layer > Copy. Then, rightȬclick the data frame where you
want to move the layer > Paste Layer. To remove the original copy of the
layer, rightȬclick it > Remove. NOTE: Too many data frames can make your
map document complicated and prone to crash.
The layers in only one data frame can be displayed at a given time. It does
not matter which data frame is listed first in the table of contents; it
matters which one is “active”. To display and work with the layers in a
data frame, rightȬclick the data frame in the Table of Contents > Activate.

The Standard Toolbar

Most typically appears at the top of the ArcMap application window and is used for map printing,
creating a new map, opening an existing map, saving your map, starting related ArcGIS applications,
and more.

The Tools Toolbar

Used for map navigation and query within the active data frame.

1

2

3

4

5

6

7

8

9

10

11

12

13

1 and 2: The Zoom In / Zoom Out tools let you click on your map to zoom in or out at a fixed amount
or to draw a box around the area that you want to see in more or less detail. The new map will be
drawn so that the area you drew the box around is in the middle of the map display.
3 and 4: The Fixed Zoom In / Fixed Zoom Out tools work like the zoom tools when you click them
rather than draw a box. Each time you click, you will zoom in or out a fixed amount.
5: Think of the Pan tool as a sticky hand. Left click on your map display, hold the mouse button
down, and move your map. Your extent (amount zoomed in or out) stays the same while your map
moves.
6: The full extent button will zoom in or out so that all of your active (checked) map layers can be
viewed. You can also zoom in to a single layer by right clicking on the layer in the table of contents
and choosing “zoom to layer.”
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7 and 8: The Go Back to Previous Extent (7) button allows you to return to the extent you had before
using one of the zoom tools. The Go to Next Extent button (8) allows you to jump forward an extent
(after you have used the previous extent button).
9 and 10: The Select Features tool (9) allows you to select features on the map. The default in ArcMap
is to select features on the topȬmost layer. The Clear Selected Features tool (10) clears any selected
features on an active layer.
There are several ways you can select features with the Select Features tool: with your mouse pointer
by clicking them one at a time or by dragging a box around them on the map. You can also select
features in the map by selecting their records in the table or graph window with your mouse pointer.
Features are simultaneously selected on the map, in a table, or in a graph. In order to view just the
selected features in the attributes table, right click on the map layer that contains the selected
feature(s) and go to “open attribute table.” This table includes all the attributes of all the features in
that layer. In order to view just the selected feature(s), click on the “selected” button at the bottom of
the table.
Applying a selection is also a way of specifying the features for which you want to calculate statistics,
view attributes, move, and so on.
11: The points, lines, and polygons that make up map layers are all map features that have attributes
stored in a table. You can access this information in several different ways. Using the Identify tool,
click on a map feature in the map display. An “identify results” box will display all of the
information known about that feature. Notice the layers dropdown menu. The default in ArcMap is
to display information only about the topȬmost layer.
12: With the Find button, you can explore and query your data by finding particular geographic
features, addresses, and places. Once the results of a query are displayed, you can navigate to the
location. Click an entry in the results list to flash it on the map; doubleȬclick to pan to it (center the
map on its location); or rightȬclick to add a graphic marker or callout label at the place, create a
spatial bookmark, add it to a list of your favorite places, and so on.
13: The Measure tool lets you to draw a line, or a series of connected lines, to roughly measure the
Euclidean (straightȬline, as the crow flies) distance between points. When you use the Measure tool in
snapping mode, it will snap to the vertices of lines and polygons, or to point features, by default. This
makes it easy to trace over features, such as to measure the distance between street intersections. If
you want to snap to edges hold down Ctrl when measuring.

Using the Measure Tool

Click on your map at the starting point. Move your cursor to your end point, or next point, and click
once, repeating until you are done. Double click to finish. ArcMap will display the cumulative
distance in the bottom left part of the GUI (below the table of contents). Once you move your cursor
outside of the map window, your results will disappear. NOTE: The measure tool will use the display
units you specified in the Data Frame Properties (right click on the name of the Data Frame > Properties >
“General” tab).
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Adding Tools and Toolbars

View > Toolbars
To add or remove a toolbar, left click anywhere outside of the table of contents, map display, or
toolbar (somewhere gray) or, from the view menu, go to “toolbars.” Anything with a check mark next
to it will be displayed. You can also add new buttons to your toolbars from the “customize” option.
One especially helpful button allows you to zoom continuously. Choose the commands tab, scroll
down to “pan/zoom,” then right click on the “Continuous Pan and Zoom” button on the right and
drag it to your tools toolbar (the toolbar with the outline of a hand and an image of a globe in the
middle) and release.

Showing Map Tips

From the Table of Contents, rightȬclick on the layer > Properties >
“Display” tab > check the “Show Map Tips” box
Map tips are small text boxes that appear when you hold the cursor
over a map feature. You can determine which value in your attribute
table is used in the map tips. To change the primary data field, make
the “Fields” tab active in the “Layer Properties” dialog box and
choose a field from the “primary display field” dropdown menu.

Getting Data into ArcMap

File > Add Data ȬorȬ Click the “Add Data” button
From ArcCatalog, you can click and drag shapefiles right into ArcMap (click on the file name in
ArcCatalog and hold down, dragging to either the table of contents or map window and letting go).

Removing Data from ArcMap

From the Table of Contents, rightȬclick the layer > Remove
This doesn’t delete the original file. It just removes the layer from ArcMap.

Saving Your Work

ArcGIS can integrate many different types of data into maps. The most common forms are tabular
data and geographic data, but you may also use various images. Through ArcMap, you can create
additional types of files, including map documents (.mxd) and map layers (.lyr). Naming and storing
these files in a consistent manner will make your work with ArcGIS much easier.

Saving Map Documents

File > Save As
If you save all of your work in ArcMap (by going to the file
menu, “save” or “save as”), you will create a map document
(.mxd). This file will save all of the work you have done,
including the data you have added and the changes you
have made to layer properties, symbology, and the layout.
This .mxd file does NOT save all of the data you included in
your map. Instead, it includes information about the location
of those files on your computer (or network, or Internet) and
the formatting changes you made. This means that you
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cannot move the data files you’ve included in a map document without running into problems. It
also means that map documents are difficult to transfer from one computer to another. If you do
move one of the files used in your map document, that layer will be shown with a ! next to it and will
not draw when you open your map document. If you click on the grayed out check mark beside the
layer name, ArcMap will bring up a dialog asking where you moved the file. Navigating to the file in
its new location and clicking “add” will solve the problem, but this can be timeȬconsuming (and
frustrating) and is best avoided.

Using Relative Paths

File > Document Properties > click the “Data Source
Options” button > select “Store relative path names
to data sources” radial.
One way to minimize problems when you move
files that are part of an ArcMap document is to use
relative paths. If you specify that you want to use relative paths, ArcGIS will be able to find the pieces
of your ArcMap document if you move it or its components.

Map Layers

From the Table of Contents, rightȬclick the layer > Save As Layer File
In addition to saving the entire workspace with a map document, you can save an individual map
layer (.lyr). This file will store all the formatting changes you have made to the layer. This is
particularly helpful if you want to use the same layer, with the same symbology, in another map
document. As with the .mxd file, the .lyr file only includes information about the formatting and the
path to the original data (generally a shapefile).

Naming Files

Giving your files clear and consistent names will make working with ArcGIS much easier. You need
to develop your own naming convention that makes sense to you. ArcGIS can work with file names
that are more than 8 characters, but really long names can be difficult to view. ArcGIS can also work
with files that have spaces in their name, but this will create problems if you work with the Spatial
Analyst extension. Your file names should help you distinguish the
content and version of your data.

Storing Files

The most important thing in storing files for ArcMap is to think through
a system BEFORE you start. Consider creating a new directory for each
new mapping project. Keep all map documents in that directory. Create
subdirectories for tabular data that are not associated with geographic
files, geographic data, and images. Keep map layers in the subdirectory
for geographic data.

Geodatabases

Geodatabases allow for topologically integrated features, similar to coverages used in ArcInfo, and
define rules for the behavior of different types of objects. This provides a much more sophisticated
approach to storing and managing data than using directories and subdirectories, and it works well
for sharing data.
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Introduction to ArcGIS Desktop Help

From Windows, click the Start button > Programs > ArcGIS > ArcGIS Desktop Help > ArcGIS Desktop
Help
Sooner or later, you will need help
with ArcGIS software. ArcGIS
Desktop Help is the first place you
should turn to get answers to basic
technical, functional, and operational
questions about ArcGIS applications.
You can access ArcGIS Desktop Help
several ways:

x

From Windows, click the Start
button > Programs > ArcGIS >
ArcGIS Desktop Help > ArcGIS
Desktop Help

x

Press the F1 key from ArcMap or
ArcCatalog

x

From any ArcGIS application,
click “Help” from the Main
Menu, then click ArcGIS Desktop
Help

The ArcGIS Desktop Help system
contains a navigation pane—with
Contents, Index, Search, and Favorites
tabs—and a topic pane for viewing
Help topics. Both panes are visible in
the viewer at all times, allowing you
to keep track of where you are in the
Contents structure of the Help system.

Searching Help for Key Words

From ArcGIS Desktop Help, click
“Search” tab
If you want to learn how to perform a
specific task or if you need more
information about a specific concept,
it is best to search for Help topics that
contain specific key words or phrases.
After opening ArcGIS Desktop Help,
click the Search tab. Type the key
words you want to find. Click Ask.
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All the topics in the Help system will be searched for the word or words entered. Click the related
links that appear (in order of relevancy) to display the topic. View the topic in the topic pane on the
right. NOTE: Use double quotation marks to string together words in the search.

Getting Help Directly Within the Applications

When you position the mouse pointer over a button or menu command, the name of the item
appears. A brief description also appears in the status bar at the bottom of the application window.

x

To get help on a command in a dropȬdown menu or button in a toolbar, click the Whatȇs This tool

x

on the ArcMap or ArcCatalog Standard toolbar, then click the item.
To get help on a command in a context menu (menu launched by rightȬclicking), highlight the
command and press Shift + F1.

x
x

To get help on a control in a dialog box, click the “Whatȇs This?” button at the top of the dialog
box and click the control. On some dialog boxes there are also About or Help buttons, both of
which provide additional Help information specific to the dialog box.
To get help on a window, such as the Table of Contents or the Identify Results window, click
inside the window, then press Shift + F1.

Direct access to the online Help for each tool and toolbox in ArcToolbox is available by using the
“Show Help” button—in the tool’s dialog box, which provides a general description of the tool and
documentation for each parameter within a toolȇs dialog box.
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Map Symbology

From the Table of Contents, rightȬclick the layer > Properties > “Symbology” tab
ArcMap has many options for changing the way your data are displayed. To make quick changes,
click on the layer symbol in the Table of Contents. The “Symbol Selector” window that opens will
look different depending upon the type of layer: point, line, or polygon. For points, you can choose a
different marker from the default. When you choose a new marker, the default size jumps to 18 point
(quite large). You can change the color, size, and angle using the options on the right of the window.
For lines, the options are similar. For polygons, you have choices about the fill pattern, fill color, and
outline color. You can find many more symbols
by clicking the “More Symbols” button. NOTE:
Remove the check mark next to one of the categories
of symbols if you find that it is not helpful (to reduce
the amount of scrolling necessary to find appropriate
symbols).
The “Reset” button will undo any changes you
have made to the symbol since opening the
symbol selector window. The “Properties”
button gives you additional options (and often
too many options) but may be helpful in fineȬ
tuning the symbol’s appearance.

Symbolizing Point Features14

Symbolizing features means assigning them
colors, markers, sizes, widths, angles, patterns,
transparency and other properties by which they can be recognized on a map. Symbols may look like
the objects they represent, as when the lake polygon is blue. Or on a street map, varying line
thickness may show whether the street is a local road, an arterial, or a highway without implying that
the widths on a map are proportional to the widths of the actual streets. By varying simple
properties, you convey information about map features.

Single Symbol

The default in ArcMap is to represent all points with the same size, shape, and color symbol. This is
how ArcMap will display your point shapefiles when they are first added to a map document or
when you create them through geocoding or adding XY data. Open the layer properties (doubleȬclick
on the shapefile name or right click and go to
“Properties,”) and click on the “Symbology” tab.
In the box on the left side, “single symbol” will
be highlighted. You can change the size, shape,
or color of the symbol by clicking on it, but as
long as “Single symbol” is selected, all of your
points will appear the same.
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Unique Value

Unique value allows you to use a different symbol for
each of the points in a shapefile. This can work well
for small files (10 or fewer points) but can quickly be
overwhelming for larger files. From the symbology
tab, click on “categories” (under “Show:”), and
“unique values.” Using the “Value:” dropdown menu,
select the field with the values you wish to use to
represent your points, and click the “Add All Values”
button.
ArcMap will list a symbol for “<all other values>” that you can remove by taking away the check
mark. You can change the individual symbols by clicking on them. You can make changes to all of
the symbols, or selected symbols (hold down the shift key to select two or more) by right clicking. To
remove a value, right click on it and choose “Remove Value(s).” Use the black arrows on the far right
to move values up and down (the order here will be the order your values appear in the legend on
your map).

Graduated Symbol

Graduated symbols allow you to have different size
symbols to represent different attribute values. With
the symbology tab active, click on “Quantities” and
then “Graduated symbols.” From the “Values:”
dropdown menu, select the field with the values you
wish to use. The default is five categories, so five value
ranges represented by different size dots should
appear below. Use the “classes” dropdown menu to
change the number of categories.
There are many ways to break up value ranges into categories. The default is “Natural Breaks,”
which uses Jenks optimization to identify grouping of values that minimize withinȬgroup differences.
To change this, click on the “Classify” button and use the Method dropdown menu to choose a
different classification system. You can also adjust the cutoff points by moving the blue vertical lines
in the histogram below that show the frequency of values. Alternatively, you can change values
manually on the previous screen by clicking on them (you will only be able to change the ending
value).

26

GIS for Public Safety

Create New Symbols from Bitmap Images15

ArcGIS provides a basic set of fonts (symbols) to use for representing point features. The default
appearance of these symbols can be edited by clicking on the “Properties” button in the “Symbol
Selector” dialog box. This will open the “Symbol Property Editor” where certain minor edits can be
made.

You can also create your own symbols by converting any bitmap (.bmp) image.
All you need is a basic graphics program that can save images in a bitmap (BMP)
file format. The Paint application, which comes standard with Windows
Operating Systems software, will suffice.
You can draw your own bitmap image or use a preȬexisting one (be careful about copyright issues).
For example, you might use an image of a school bus to identify locations of school bus stops on a
map. If this image is already a bitmap image file, then you can skip to the next step. If it is JPG, GIF,
or some other file format, you must first convert it to BMP. To quickly convert a JPG or GIF image to
BMP, open it in Windows Paint (usually located in the Start Menu > Accessories). Once opened, save
it as a BMP by going to File > Save As. If necessary, you can change the file type in the “Save as type”
drop down menu.
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Start ArcMap and go to Tools > Styles > Style Manager. In the “Style Manager” window, click the
appropriate folder on the left, so that you can see a list of folders on the right—one of which will be
“Marker Symbols”. RightȬclick on the “Marker Symbols” folder and choose New > Marker Symbol.

The “Symbol Properties Editor” window will
open. In the “Type” dropȬdown menu, choose
“Picture Marker Symbol”. Browse to the location
of your BMP image and import it by clicking the
“Open” button.
Make any necessary edits to the image size,
background color, or transparency. Click OK
when finished. When you click OK, the “Style
Manager” window will reappear; you can name
your new symbol. Click the “Close” button. The
new symbol will be accessible from ArcMap’s
Symbology Selector. Repeat these steps for each
new symbol.
ImageȬderived symbols can take more time to
refresh on a map than basic ArcMap symbology
(depending on the size of the image). Therefore, if
you have many points, displaying these symbols
on a map can take considerable time and may
frustrate your other preliminary GIS analysis
tasks. To avoid this, use basic (e.g. default)
symbols in preliminary steps and change to
imageȬderived symbols for your final map layout.
Another word of caution: use picture symbols
sparingly. Remember that the purpose of your
map is to communicate information. While clever
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symbols might get the “ooosȬandȬaaahs”, they are not always the best method to impart information.
If the symbol is too small, unclear, or unȬinterpretable, it could create confusion and/or draw
attention away from the main purpose of the map, thereby diminishing its value. People get
distracted easily. Furthermore, a cartoony (and stereotypical) image of a burglar to represent
burglaries may appear unprofessional. Conversely, a handgun to represent shootings or a car to
represent auto thefts may reduce the need of the map reader to refer backȬandȬforth to the legend.
Then again, guns could also represent “unlawful possession” or “registered gun permit holders”, and
cars could represent “traffic accidents” or “carjacking”. Pictures do “speak a thousand words”, but
you do not want them to speak more than your map’s legend.

Symbolizing Polygon Features

The symbols in ArcMap can be used for any type of data—points, lines, or polygons. The following
symbology schemes work particularly well with area (polygon) data.

Graduated Color

You can use different colors—or different shades of the same
color—to represent different values to create choropleth
maps. From “Layer Properties,” click on the Symbology tab.
On the left side of the screen, click on “Quantities” and
“Graduated Color.” Choose the field with the values you
wish to use. Use the “Classes” dropdown menu and the
options in “Classify” to change the number of categories or
method for breaking values into categories. You can
normalize a value in order to transform it into a rate using
the “Normalization” dropdown menu. For example, in order to show the percent of households
receiving public assistance, normalize the total number of households receiving public assistance by
the total number of households. Choropleth maps are best used to represent rates rather than raw
counts since raw counts can look deceptively large for large polygons (alternatively, you can create
new fields in your attribute table corresponding to rates). Graduated color works best when you use
the same shade of a single color, with lighter shades representing lower values and darker shades
representing higher values. But keep in mind that it may be impossible to distinguish between more
than four or five shades of the same color, depending upon the quality of your printer.
To fineȬtune colors, go to “more colors” when choosing a color from the symbol
selector. Here you can play with the hue(H), saturation(S), and value(V).

Fill Patterns

You can use different patterns in addition to, or instead of, using
different colors to represent different values. Patterns are
particularly helpful when you are restricted to printing maps in
black and white. Choose “Graduated Colors” from the Symbology
tab and select the field with the values you want to display. Set the
number of classes and the method of classification, so that you are
happy with the value ranges. Then click on the symbols and
change the fill using the symbol selector. Click on the Properties
button to fineȬtune the fill pattern.
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Dot Density

Dot density maps use randomly placed dots within
polygons to represent different values. They provide
an alternative to using choropleth maps to represent
raw counts, although it is important to remember
(and communicate to anyone reading your map)
that the points do not represent precise locations.
To create a dot density map, open the Layer
Properties and make the Symbology tab active. Click
on “Quantities” and “dot density.” From “Field
Selection,” choose the field you wish to use as the
basis for the map. Counts (such as the total number of households on public assistance) are
appropriate for dot density maps, but averages, medians, and rates are not. Choose your dot size, or
keep the default (which is advisable, at least to start). The “Min,” “Mean,” and “Max” boxes will give
you a preview of how your map will look. The “Dot Value” indicates how many units each dot
represents. Change this as needed to create dot densities that have enough dots to show variation but
not so many that they are all on top of each other. You can change the color of the dot by clicking on
it under “Symbol” in the top right part of the screen. Checking “maintain density” will ensure that
the dot density looks the same as you zoom in and out (by making the dots bigger and smaller).

Pie Charts

Charts are good for showing multiple values and the relationship
between values on different variables. Pie charts are especially good for
showing proportions. For example, individual pie pieces can be used to
show the breakdown in race for the population in a census tract. Pies
contain a lot of information, so it can be difficult to display them clearly.
To create pie charts, click on “Charts” and “Pie” from the Symbology tab. Holding down the Ctrl key,
select the fields that you want to include. Make sure that together, they add up to 100 percent (you
may need to create and calculate a new “other” field in your attribute table before using charts). Click
on the “Background” button to change the color or fill (“Hollow” or white backgrounds might be
best, so that you don’t have too many colors in your map). If you check “Prevent Chart Overlap,”
ArcGIS will use “leader lines” to indicate where the pie charts belong if there is no room to display
them within the map feature. Click on the Properties button to make adjustments to the look of the
pie (3D, rotation, height).
Click on the Size button if you want to have different
size pie charts depending upon the total (such as total
population). If you choose to “Vary size using a
field,” you may need to exclude records with a zero
value. To do this, click on the Exclusion button and,
using the appropriate field name, create an expression
such as “POP2000=0”. You may need to play with the
minimum size on the previous screen to make the
maximum size pie chart a reasonable size.
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Bar/Column Charts

Bar charts can be used to compare values on two or more variables that do not represent proportions
(they don’t have to be subsets that add to 100 percent). To switch from column (vertical) to bar
(horizontal) charts, go to Properties on the Symbology tab of Layer Properties and switch the radio
button under “Orientation.”

Stacked Charts

Stacked charts can be used to compare values on two or more variables (such as gender) that are
subsets of a larger variable (such as total population) when you don’t know, or don’t want to display,
all of the subsets. You have many of the same options for formatting (size, color) that you have with
the other types of charts.

Classification Methods/Schemes16

ArcGIS provides several standard classification options.
The most common are manual, natural breaks, quantile,
equal interval, and standard deviation. Manual lets you
set the class breaks manually if, for example, you want
to emphasize certain features or patterns. Specify the
class breaks by manipulating the histogram or entering values
directly in the “Break Values” box to the right of the
“Classification” dialog box. “Natural breaks” or “Standard
deviation” methods work best with unevenly distributed or
skewed data. “Quantile” or “Equal interval” methods work best with evenly and normally
distributed data.
The default classification method in ArcGIS is natural breaks, whereby a statistical procedure
identifies feature pairs, between which there is a relatively large difference in data value, so that class
breaks are set to correspond with relatively large jumps in the distribution of values.
The quantile classification method arranges all observations from low to high and assigns equal
numbers of observations to each class. If 20 census tracts and four classes exist, then each class will
contains 5 census tracts, with the lowest 5 in the first group and the highest 5 in the last group.
“Quantile” emphasizes the percentage of observations in each category and is best suited for linearly
distributed data. Note that differences between classes can appear exaggerated with this approach
because of the way in which values are grouped together.
The equal interval approach divides the distribution of values so that the difference between the
highest and lowest value is the same for each class grouping. “Equal interval” is best used with
familiar data ranges such as percentages and temperature. With highly skewed data, most
observations will be assigned to the lower or upper value categories and only a few observations will
be assigned to the other categories. This could be useful to emphasize outliers in data (such as
exceptionally high crime rates) but its limitations should be noted.
The standard deviation method emphasizes how much feature values vary from the mean. It shows
how far each class category is from the mean, not the actual values in each class. With positively
skewed distributions, outliers and clusters can easily be identified (remember the 68Ȭ95Ȭ99.7 rule?).
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Adjusting Transparency

From ArcMap’s Table of Contents, rightȬclick the layer > Properties > “Display” tab.
Adjust the transparency value (%) in the “Transparency” text box.

Querying GIS Data
Query by Attribute

In GIS, you can identify a subset of map features based on their
attributes or their location. You may use queries as an intermediary
step, as part of getting to know your data, to create new values, or
to answer your research questions.

Select by Attribute

From ArcMap, Selection > Select by Attributes
Your first step in the “Select by Attributes” dialog box is to select a
layer that you wish to query (attribute queries are limited to a single
layer). In the Method drop down menu, you need to decide whether
you are building on a previous query or starting fresh. From here,
the query dialog is similar to “Calculate Fields.” Build an expression using the field names and
functions, connecting statements with “AND” or “OR” as necessary. The values associated with each
field will be displayed in the text box at the far right. You can use these or type in your own. If you
want help working through these steps, click on the Query Wizard button. Click “Verify” to make
sure ArcMap likes your expression. You can import (Load) and save expressions using the buttons
OR using Ctrl + C and Ctrl + V with a word processing file. NOTE: if the values you input are text rather
than numbers, then you need to put single quotes around them (for example, ‘BROAD’).
When you click “Apply,” the map features that satisfy your query will be highlighted with a bright
blue outline. You can perform an additional query (adding, removing, or selecting from this selected
group) or close the query dialog. To review the selected records, right click on the map layer and go
to “Open Attribute Table.” Click on the Select button at the bottom to view only the selected records.
You can calculate values on an existing or new field for only the selected records (for example,
calculating the percent of multiracial people only in block groups with nonȬzero populations). You
can also generate summary statistics for only the selected records by right clicking on a column name
and going to “Statistics.” To see all of the selected records at the closest extent, from the Selection
menu, go to “Zoom to Selected Records.” NOTE: You can create a new shapefile that only includes your
selected map features by right clicking on its name in the Table of Contents, going to “Data” and “Export
Data.” Choose the radio button regarding coordinate systems (you’ll probably want the default). Make sure you
have “Selected Records” chosen in the Export drop down menu.
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Select by Location

From ArcMap, Selection > Select by Location
The ability to query based on the location of map features
is something unique to GIS, and combining attribute and
location queries really takes advantage of GIS
functionality.
Your first choice in the “Select by Location” dialog box
involves the nature of the selection. Are you starting
from scratch or querying a subset of map features
already selected? In the next box, put a check mark next
to the map layer(s) whose features you wish to select.
The drop down menu then provides various
relationships between the features in that layer and a
subsequent layer (identified in the next drop down
menu). For distanceȬbased queries, you will be able to
select your units as long as the map units have been
specified in the Data Frame properties. The
options/images at the bottom of the dialog box change as
you choose a different type of relationship as the basis of
your location query.

Combining Attribute and Location Queries

The “Select by Attribute” and “Select by Location” dialogs do not allow you to mix the type of query.
But by performing one type of query first and then conducting a subsequent query on the selected
records, you can perform attribute and location queries on the same map layer. For example, you
may be interested in what census tracts are located along a river, but you are only interested in
census tracts that have at least 100 people living in them. It doesn’t matter which query you do first.
Just be sure that the selection method you choose for the second query allows you to add, remove, or
select from the records selected from the first query.

Removing the Selection of Features or Attributes
Selection > Clear Selected Features
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Labeling Features

Labeling features in ArcMap can be tedious, but labeling features well is important to making your
maps communicate effectively.

Using Text Boxes to Label Features

From ArcMap’s “Data” view, click the “A” button on the
“Drawing” toolbar > click the “A” > click on the map where
you want the text to appear > type in the text box > hit the
Enter key (or click the cursor outside the text box) to
complete.
You can place text on a map in order to label map features. This works well if you only have a few
map features to label. The “A” with the different shapes behind them allow you to add text within a
polygon background.

The
lets you to draw a polygon shape. The rectangle lets you to draw rectangles, and the circle
lets you draw circles.
You can move the text around using the “Select Elements” tool
. Double clicking on the text will
bring up the Properties, where you can change the size and font (using the “Change Symbol” button).
The callout text tool
allows you to place your text away from the
map feature while still indicating what is being labeled. Click on the
tool and then click on your map feature. Before letting go, you can
move the cursor to where you would like the label to be. Type your
label. Using the “Select Elements” tool, you can move the text box so
that it is closer or further from the map feature.

A third option is the spline text tool. This
allows you to write text along a curved line.
This works well for labeling rivers and curvy
roads. Click on the spline tool, then click on
the starting point for your label. Continue to
click along the curve (you don’t need to make
many clicks) and double click to finish. Then
type your label in the text box. You will
probably need to try this several times to get a
label with which you are happy (just click on
the label with the “Select Elements” tool and
hit the “delete” key to delete a label).
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Manually Placing Labels

Click the “A” button on the “Drawing” toolbar > click the “Label” tool
Using the label tools in ArcMap, rather than the text tools, allows you to use the values in a layer’s
attribute table for your labels (in other words, you don’t have to type the label out as you do with the
text tools). By manually placing labels, you also avoid having your labels act as a group, which means
it is easier to move or edit a single label. Before you can use the label tools in ArcMap, you need to
indicate which field in the attribute table of your map layer you want to use as the basis for labels.
From Layer Properties, click on the “Labels” tab. Leave the “label features in this layer” box empty.
Choose the appropriate field from the Label Field dropdown menu. Click on symbol to change the
size, style, or font for your labels. (Guessing what size to make your labels is difficult and you will
probably need to make small adjustments after seeing what works). Using the “Placement
Properties” button, you can instruct ArcGIS what
to do about duplicate labels.
The “Scale Range” allows you to instruct ArcGIS
when to draw or not draw labels, depending on
the extent. In order to do this, you need to know
the exact scales you will be using (so you probably
just want to leave this alone). The “Label Styles”
button gives you access to some fancier label
options. The highway labels are particularly
helpful.
Now you can use the label tool to manually label your map features. Click
on the button marked “A” on the drawing toolbar and choose the “Label”
tool
. The “Labeling Options” window will open. Select if you want
ArcMap to decide the best label position or if you want to determine that
yourself. The “Choose a style” radio button gives you access to those
fancier labels again. You can move these labels (using the “Select
Elements” tool) and change their size and style (double click to bring up
Properties). You can delete a label by clicking on it and pressing the delete
key.

Auto Labeling

From the Table of Contents, rightȬclick the layer > Properties > “Label” tab > check the “Label
Features in this Layer” box
You may find it easier to automatically label all of your features. This saves time if you are happy
with the way the labels look, but it offers you much less control over the label placement. When you
automatically label features, the labels are “dynamic” so changes you make to one (e.g. changing the
style) are made to all. To delete your labels, you will need to remove the check mark from “Label
Features in this layer” box. NOTE: you can also label automatically by rightȬclicking a map layer and going
to “Label Features.”
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Converting Labels to Annotation

From the Table of Contents, rightȬclick layer after
labeling it > Convert Labels to Annotation
Labels are one option for placing text on an ArcGIS
map. Labels are positioned on the map by the software
based on a set of labeling properties defined in the
“Labels” tab of the “Layer Properties” dialog box. If
you want full control over where labels are placed, you
must convert them to annotation.

Using Annotation Layers

After labels have been converted to geodatabase
annotation, the annotation class is automatically added
to the map. Annotation groups are listed in the Data
Frame Properties dialog box on the Annotation Groups tab. In the Table of Contents, rightȬclick the
Layers data frame and click Properties. Click the Annotation Groups tab. Annotation labels can be
toggled on or off, and their properties can be changed in this dialog box. Click the group that you
want to use and then click the Properties button. Click the Associated Layer dropȬdown list and click
<None>. This allows you to turn the annotation layer on and off independently from the map layer.
Click OK, then click OK again.

Designing Map Layouts

Displaying data so that you can analyze spatial patterns on a computer screen is one thing; printing
out a map for other people to look at is another. ArcMap thinks of these as distinct functions and
makes available a series of tools for designing map layouts that you don’t need until you are ready to
print.

Layout View

View > Layout View ȬorȬ Click the “Layout View” button at the
bottom of the map display
When you open ArcMap, you are in “Data View” and use the
“Tools” toolbar to navigate your map. When you switch to the “Layout View”, you have access to a
different range of tools and use the “Layout” toolbar to navigate. In Layout View, you get a much
better idea of how your map will look when it is printed.
ArcMap will automatically place a border (“neat line”)
around your map. You can change this by right clicking on
it and going to “Properties.” Click on the “Frame” tab.
From here you can choose a different style or color frame
(to get rid of it altogether, choose “no color” from the color
selector). You can also change the background color and
add a shadow (to add a shadow, you’ll need to change the
X and Y offset to something other than 0).
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To make your map larger or smaller on the page, you can use the zoom tools on the Tools
toolbar or on the Layout toolbar. The Layout toolbar also includes a pan tool that you can
use to move your whole layout. To move just your map (and not the whole page), use the
pan tool in the Tools toolbar. The fixed zoom tools in the Layout toolbar work like the
ones on the Tools toolbar. The “Zoom to whole page” button

is especially useful.

One of the biggest differences in Layout View is that many more
options in the “Insert” menu become active. These options allow you
to add elements—including a title, legend, north arrow, scale bar, and
image—to your layout. Each of these will be separate objects in your
layout that can be moved and resized through their Properties. You
won’t see any of them if you switch back to Data View since they are
meant to clarify printed maps, not help you
Tools Toolbar Æ
interpret your map on the screen. You can add
text in the Layout View, but you are better off
Layout Toolbar Æ
trying to label features from the Data View,
using the label or text tools.

Page and Print Setup

From ArcMap’s Layout View, rightȬclick the page > Page and Print Setup
By default, the paper size in Layout View is 8.5” x 11”, portrait orientation. Make adjustments to the
paper size, orientation, and margins, or add page guides from the “Page and Print Setup” dialog box.
The paper size, not the data frame’s size, dictates the size of the image (i.e. JPG) that will be exported.
Guides are very helpful for aligning map elements, which can be forced to “snap to guides” to ensure
proper and consistent alignment.

Adding a Title

From ArcMap’s Layout View, Insert > Title
Type your title in the text box and hit the enter key or click the cursor outside the text box. DoubleȬ
click on the title to bring up the Properties where you can make formatting changes.
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Adding a Legend

From ArcMap’s Layout View, Insert > Legend
Unless your labels are able to fully explain your map
features, you will need a legend on your layout. ArcMap
gives you flexibility in formatting your legend, and all
the choices can be overwhelming. Your first choice in the
“Legend Wizard” is what map layers you want
included. ArcGIS will guess that you want to include all
active layers. This may not be the case if you have layers
such as a county boundary, rivers, or other obvious
features that do not need to be included in the legend.
To remove a layer from the legend, click on its name on
the right side of the Legend Wizard dialog box and click on the “<” button. The order your layers are
listed under “Legend Items” will correspond to the order in which they appear in your legend. To
change the order, click on the name and hit the up or down arrows (don’t worry; this won’t affect the
order in which they are drawn). If you want more than one column in your legend, make the
adjustment here. To see what your legend will look like (before working your way through the rest of
the screens), click the “Preview” button. If you are satisfied with it, you can click the Finish button
and skip the other steps. Otherwise, click the “Preview” button again and click “Next.”
On the second screen of the Legend Wizard, you can give your legend a title or leave the word
“Legend” as the title (or just leave it blank). The third screen allows you to create a frame and
shadow around your legend (not necessary, but depending upon your layout it may be helpful,
particularly if you gave your layout a background color). On the fourth screen, you can change the
symbols and symbol size used to represent lines and polygons in your layout. On the final screen,
you can make adjustments to the spacing between items in your legend. Click “Finish.”
To make changes after you have created
your legend, double click on it to bring
up the “Legend Properties” dialog box.
You can change the legend’s appearance
by clicking the “Style” button in the
“Items” tab of the Legend Properties
window. The “Legend Item Selector”
dialog box will appear with a variety of
legend styles to choose from.

Adding a Scale Bar

From ArcMap’s Layout View, Insert > Scale Bar
To add a scale bar, you must identify the appropriate units for your
map. You can set these from the Data View or Layout View. From
Layout View, right click in the layout (anywhere inside the neat lines),
go to Properties, and make the General tab active. From the map units
dropdown menu, choose the units used for the original map projection.
Once this is set, you can choose any display units you want.
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From the “Scale Bar Selector” dialog box (Insert > Scale Bar), select a style and hit “OK.” Your scale
bar should appear on your map. You can move or resize it by clicking on it. Double click to bring up
the Properties, where you can change the number of divisions as well as the font size (by clicking the
Symbol button or from the format tab).
The number of divisions, subdivisions, and frequency of numbers and
marks can be adjusted manually by right clicking on the scale bar and
selecting “Properties”. The Scale Line Properties dialog box will
appear. Adjustments can be made under the “Scale and Units” or
“Numbers and Marks” tabs.
To change the number format, click the
“Number Format…” button in the
“Numbers and Marks” tab. In the
“Number Format” dialog box you can set
the number of decimal places, add or
remove thousands separators, and more.

Adding Scale Text

From ArcMap’s Layout View, Insert > Scale Text
You may wish to include a text description of the map scale,
particularly if this is important to your audience and you deliberately
chose a scale. To make changes to or format the units of the scale text,
doubleȬclick it in the Layout to bring up the Properties.

Adding a North Arrow

From ArcMap’s Layout View, Insert > North Arrow
Choose a style from the “North Arrow Selector” (preferably something
simple and small). You can move it around on your layout by clicking
on it. DoubleȬclick to change the size or style.

Rotating a Map

From the “Data Frame Tools” toolbar > click the “Rotate Data Frame”
button
You can rotate a map to better fit the page or to make it easier to read (just because you can do this
doesn’t mean it’s a good idea). If you do this, make sure that you have a north arrow on your map.
As you rotate your map, your north arrow will adjust to indicate which direction is north. Using the
“Rotate Data Frame” tool, click and hold, moving your map to change the rotation. To restore the
original orientation, click on the “Clear Rotation” button.

Map Templates

Using map templates can save you time and lead to greater consistency in your printed maps. You
can use ArcMap’s custom templates or design your own. When you open a template, you get a new,
untitled ArcMap document plus any layout or data that was saved in the template. This means that
some templates provided by ESRI include (projected) base layer shapefiles.
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Opening Map Templates

File > New
Decide if you are going to use a map template before you start
adding data to your map document. When you open ArcMap,
choose to start using ArcMap by clicking on the template radio
button in the dialog box. The templates listed in the General and
Industry tabs provide empty layouts while those in USA and
World tabs include base map layers. Choose a template by
double clicking on its name or clicking once and hitting “OK.”
Don’t worry if the template includes colors or elements that you do not want. It only provides a
starting place and you will have the opportunity to customize it.
If you have turned off the opening dialog box (by putting a
check in the “Do not show this dialog again” box when you
opened ArcMap previously), go to the File menu and “Open.”
From the “File or type” dropdown menu, choose ArcMap
Templates (*.mxt). Navigate to ArcGIS’s template folder
(probably C:\Program Files\ArcGIS\Bin\Templates) and
choose a template. You can’t preview the templates if you access
them this way.

Using Map Templates

If you selected a map template that contains no data, you must add one or more data layers to your
map document. Once you do, the legend and other elements of your layout will be automatically
created based on the template design. Make changes to the data frame (which contains your map),
legend, scale bar, and north arrow from the Properties dialog boxes (right click on any of these and
go to Properties). You can also move the elements around (click and hold down) as needed. Notice
that when you use map templates, ArcMap opens in Layout View. You can still switch back and forth
to Data View using the

buttons.

Using Inset Map Templates

For the map templates that include insets, you will need to add at least
two layers. When you open one of these templates, you will see Layers
1 and Layers 2 listed in your table of contents. By having two separate
groups (i.e. Data Frames) of layers, you can have two maps in your
layout. This might be two different maps or the same map at different
extents. Right click on “Layers” and go to “Add Data” to select the
map layer for the main map in your layout. Then right click on “Layer
2” and, from “Add Data,” find the map layer for the inset map.

Creating Your Own Template

File > Save As > from the “Save as type” dropȬdown menu, select
“ArcMap Template” ȬorȬ File > New > “My Templates” tab > at the
bottom left, select the Create New “Template” radio.
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You can create your own map template by modifying an existing custom template or starting from
scratch. Once you have created a layout that you would like to reuse, go to the File menu and “Save
As.” From the “Save as type” dropdown, choose “ArcMap Template (*.mxt).” If you are not in the
ArcGIS Template folder, navigate to it (c:\ArcGIS\arcexe82\Bin\Templates). Give your template a
name and hit “Save.” Your new template will appear under the General” tab when you choose to
start using ArcMap with a template (You must save your template in the Templates folder in your
profiles location in order for it to appear under the “My Templates” tab. If you create a new
subdirectory in the Bin/Templates folder, your templates will appear under a new tab with the name
of your subdirectory).

Creating Extent Rectangles (Inset Maps)

From the Table of Contents, rightȬclick the (receiving) data frame >
Properties > “Extent Rectangles” tab
You may need to create a map layout that includes more than one
map, either because you cannot fit everything (such as Alaska and
Hawaii) on your main map or because you want to zoom into a small
area for your main map and indicate on a smaller map what area that
covers.
Extent rectangles show the extent of one data frame within another
data frame. They are dynamic: if you change the extent of either data
frame the extent rectangle will update automatically. Extent rectangles
also update when the data is rotated or when the projection is changed.
To
create
an
extent
rectangle, start with at least
two Data Frames: a detail
layer and an overview layer
(See “Data Frames” section
in Chapter One). At least
one data frame must be
showing an extent that is
completely
within
the
extent of the other. Right
click on the data frame that
will be receiving the extent
rectangle (the overview layer) in the Table of Contents >
Properties. From “Properties” dialog box, click on the
“Extent Rectangles” tab. Click the data frame with the
smaller extent (the detail layer) to select it. Click the > button to move the selected data frame from
the left to the right side—to the “Show extent rectangle for these data frames” list. Click on the
“Frame” button to make changes to the outline of your box. Click the “OK” button to all dialog boxes.
NOTE: When you have several data frames in a map, name them clearly and descriptively so it is easier to know
which to choose when creating an extent rectangle.
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Exporting Maps

File > Export Map
If you just need paper copies of your maps, you will probably have the best results printing them
from ArcGIS. But if you need to insert maps into PowerPoint or word processing files, will need to
export your maps. You can export a map from ArcMap when you are in Data View or Layout View.
However, if you want your exported map to include titles, legends, scale bars, north arrows, and
anything else you added to the layout, you need to export from Layout View. There are many options
for export formats in the “Save as type” drop down menu.
.PDF — The .pdf format allows you to open the map directly (without inserting it into PowerPoint or
MS Word) as long as you have Acrobat Reader. This is probably the best option if you need to send
someone a map or post a map on the Internet.
.JPG — The .jpg format will compromise the quality of your image, so be sure to click on the
“options” button when you export and increase the resolution to at least 200 dpi. The .jpg format is
good because it stores your map in a fairly small file and, unlike some other file types, your map will
not be compromised if you open it on a computer that does not have ArcGIS installed.
.TIF and .EPS — The .tif and .eps formats work well if you are going to open your maps in a graphics
software package, but they result in larger files.
Screen Capture — If all else fails, you can take a screen capture (print screen, or alt + print screen)
and crop the image, but this will not result in a presentationȬquality map.
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Guidelines for Professional Map Production17
Map Communicability
The intended purpose of the map should be
clear and the map should clearly and
prominently display the information that is
intended to be imparted to the map reader.
Map Layout & Design
Maps should be refined and aesthetically
pleasing. Use a consistent layout and
cartographic element styles across multiple
but related maps. This lets the reader focus on
changes to the maps’ key features and to make
comparisons more easily across multiple
maps. Layers should be arranged with key
features on top. Be sure that the map and its
features are of adequate size, but not too large.
You don’t want maps to appear too crowded
or confusing.
Map Titles and Text
A title and/or subtitle should always be
present and should communicate the main
purpose of the map. Make sure they suggest
what your symbology and category labels
actually show. Text should be of adequate size
and a very legible font. Text is symbology too.
Different text sizes could imply differential
importance (i.e. not simply that you are trying
to fit the text within a polygon). Space on the
map layout is precious, so there is no need to
repeat the same text or phrases over again.
Text should be clear and concise. Strictly limit
your use of abbreviations in order to prevent
confusion; some abbreviations mean different
things to different people. Proofread your
maps for “floating”, or unassigned, labels and
spelling/grammatical errors.

.

Map Colors
Use as much color contrast as possible
between categories, especially with grayscale.
For example, with 3 categories, use white,
gray and black—not light gray, medium gray,
and dark gray. Darker colors commonly
represent
higher
values
(or
greater
significance), and lighter colors represent
lower values (or lesser significance). When
you reverse this, you risk misinterpretation by
your map reader. Consider the photocopyȬ
ability of your map. Color contrasts are
greatly diminished when printed or copied in
black and white or grayscale. Be sure that all
map features are easily distinguishable. Check
out ColorBrewer, a web tool for selecting color
schemes
for
thematic
maps:
www.personal.psu.edu/cab38/ColorBrewer/C
olorBrewer.html
Symbology
Never use “selection” as symbology. Be sure
that map features are identified and map
symbology is explained (e.g. polygons
represent blockgroups; shading of polygons
shows % of population below poverty). Use
meaningful class breaks.
Cartographic Elements
Maps should include all necessary (audience
appropriate) cartographic elements, including
a North arrow and scale bar. Values on a scale
bar should be easily additive, divisible, etc.;
units should be stated; numbers should not be
cluttered. Most visible features on the map
should be included in a legend, with few
exceptions. However, all items included on a
legend should always be visible on the map.
Be sure to change the layer/label names from
their defaults. Clearly and meaningfully label
class breaks and do not include unnecessary
decimal places.
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Checklist for Professional Map Production and Dissemination
Scholarship
Ŀ Good critical thinking
Ŀ Well written
Ŀ Showed creativity and innovation
Ŀ Thoughtful interpretation of maps
Ŀ Appropriately referenced maps in the
body of text when discussing them

Symbology
Ŀ
Ŀ
Ŀ

Appropriate class breaks
“Selection” not used as symbology
Features identified and symbology explained

Cartographic Elements

Map Layout & Design

Maps should include all necessary (audience
appropriate) cartographic elements.
Ŀ North arrow (present)
Ŀ Scale bar/text (present)
o Values on scale bar are easily additive,
divisible, etc.
o Appropriate number of breaks, text is not
cluttered
o Units defined
Ŀ Legend (present)
o Layer/label names changed from filenames
o All necessary features/layers are included
in legend
o All items included on legend are visible on
map
o Values of class breaks are appropriate (i.e.
no unnecessary decimal places, etc.)

Map Titles and Text

General Items
Ŀ Be careful: Text is symbology too. Different text

Map Communicability
Ŀ
Ŀ
Ŀ

The intended purpose of the map was
clearly communicated
The map seems to serve its purpose
The map makes sense

Maps should be refined, aesthetically pleasing,
and appear professional.
Ŀ Not too crowded/confusing
Ŀ Adequate map/feature size
Ŀ Layers ordered appropriately
Ŀ Consistent layout and cartographic
element styles across multiple, but
related, maps.

These are necessary to convey the
meaning/purpose of a map.
Ŀ Title/Subtitle (present)
Ŀ Title/subtitle suggest what symbology
and category labels actually show.
Ŀ Adequate text size and legible font/style
Ŀ Text and phrases are not unnecessarily
repeated
Ŀ No “floating” or unassigned labels
Ŀ No spelling errors

Map Colors
Ŀ
Ŀ
Ŀ

Good contrast
Easily distinguishable features
Used as much color contrast as possible
between categories, especially with
grayscale.

Ŀ
Ŀ

Ŀ

sizes could imply differential importance—e.g.,
not simply that you are trying to fit the text
within a polygon.
Be clear: Abbreviations don’t always mean the
same thing to everyone. For example, “N” and
“Y” don’t always mean “No” and “Yes”.
Darker colors commonly represent higher
values (or greater significance), and lighter
colors commonly represent lower values (or
lesser significance). When you reverse this, you
risk misinterpretation of your map.
Given the color contrast, map(s) may not be
photocopyȬable. This is something important to
think about.
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Inserting Maps into Microsoft Word and PowerPoint

From the application, Insert > Picture > From File > navigate to
the image file > click the “Insert” button
Save your map as a .jpg. You are probably better off creating
map titles in PowerPoint rather than ArcMap. Also, if you are
making a map specifically for PowerPoint, consider making the
legend larger than usual (14 points or more) so that your
audience can read it.

You may encounter problems displaying maps in PowerPoint or
Word if you try to show the exported map images on another
computer and it doesn’t have ArcGIS loaded. Your symbols (i.e.
the dots or other images used to represent points on your map)
may come up looking like # and other strange symbols. This is
because your exported maps are relying on the ESRI fonts to
draw these symbols correctly. If ArcGIS isn’t loaded, those fonts
are not available and Microsoft comes up with the closest
approximation from other fonts. If you use .pdf files or screen
captures, you can avoid the problem but will sacrifice image
quality and flexibility. Whenever possible, embed fonts or
convert them to curves as you export them from ArcGIS.

Picture Toolbar

The “Picture” toolbar provides several tools that let you edit
and format images in Microsoft Office applications such as
Word or PowerPoint. To activate the “Picture” toolbar (if it is
not already available) go to View > Toolbars > Picture. NOTE:
the Picture toolbar is only visible when a picture is selected. So if you
don’t see it, be sure a picture in your document is selected (i.e. click on
it with your mouse).

Cropping Map Images

You may notice that there is a lot of white space around your map. Eliminate this in MS Word or
PowerPoint by using the “Crop” tool
on the “Picture” toolbar.

Picture Format and Layout

Formatting the picture by “Wrapping” text around
maps, for example, is useful when writing policy briefs
or research reports. Click the “Text Wrapping” tool on
the “Picture” toolbar, or RightȬclick image > Format
Picture > “Layout” tab. You can also add/edit the image
border, size, and alignment from the “Format Picture”
dialog box.
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Portable Document Format (PDF) Files

Portable Document Format, or PDF, is a digital file format created by Adobe Systems for document
exchange in a manner that is independent of the original software application. PDF files are an
excellent way to distribute documents via email or online because they are generally small in file size
and can be universally viewed; no matter what computer operating system you open them on, they
will look exactly the same. PDF files can be thought of as static images of the original document’s
content.

Viewing PDF Documents

Adobe Reader is necessary to view PDF files. Many computers already come with this software
installed. However, if your computer does not have Adobe Reader installed, you can download it for
free at www.adobe.com. It is compatible with most operating systems including PC and MAC. To
open a PDF file, click (or double click) it and Adobe Reader will open automatically to display the
document.

Saving Maps and Documents as PDF

ArcMap has builtȬin capability to save map layouts as PDF. From the Layout View, go to File >
Export Map. In the “Export Map” dialog box, select “PDF” from the “Save as type” drop down menu.
This method is useful if you intend your map layout to be the final product or deliverable. However,
it is more likely that you will produce maps in ArcMap, export them as a PDF, JPG, or other image
file, and then import them into a Word Document, PowerPoint Presentation, or other software
application where you will produce the final document.
The most common (and easiest) way to turn a document into the PDF format is from within the
software application where you created the document. For example, convert a Microsoft Word
document to a PDF file from within the Microsoft Word application. A “PDF creator“ is required to
do this. Adobe’s software suite for creating and editing PDF files is not freely available and can be
expensive. If you do not have Adobe, you will need another PDF creator.
There are several free PDF creators that serve as alternatives to Adobe. “doPDF”, for example, is free
for both personal and commercial use and permits users to create highȬquality searchable PDF files
by simply selecting the ȈPrintȈ command from any application. Because the availability of PDF
creators changes constantly, it would be inappropriate to list all of the current options here. Rather,
search for “PDF Creator” on www.download.com or another reputable software website for
freeware, tryȬware, or paid software that creates PDF files and that meets your specific needs.
With PDF creator software installed on your computer, it is likely
that you will be able to convert a document to PDF by going to File >
Print, and then selecting the PDF Creator from the printer “name”
pullȬdown menu in the “Print” dialog box. Click the “OK” button;
you will likely be instructed to choose a file name and directory to
store the PDF file. Rather than printing to printer hardware, your
document will be “printed”, or “imaged,” to a
new digital PDF file stored on your disk drive.
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PowerPoint Design & Presentation Tips18
1. Dark background with light text
PowerPoint presentations look best with a dark background and light text as these are the easiest to
read and most gentle on the eye. Dark blue backgrounds are popular and are effective because the
wavelength of blue means that it tends to fade into the background emphasizing the text on top. Try
experimenting with other dark shades (but stay clear of red as a background).
2. Simple titles & points
Keep titles and bullet points short and relevant; do not overcomplicate your slides. Use the slides as a
prompt and do not read directly from them. Use about 5 key bullet points per slide. Break longer lists
into multiple slides whenever possible. A presentation should be a summary of your work, not the
whole thing. Listening to a presenter read a list verbatim from the screen is boring.
3. Font size and type
Absolute minimum font size should be 16pt. But keep in mind that with some fonts 16pt is much
smaller than in another font. If you cannot fit your text onto the screen using a font size of at least
16pt, do not reduce the size. Reduce the number of words or use multiple slides. Simple San SerifȬ
type fonts such as Arial are simplest to read. If you are taking your presentation somewhere else and
using another computer, do not use a unique font that only you might have. The host presentation
computer is unlikely to have the font and your presentation will not look as expected. Stick with basic
fonts.
4. Builds & dimming
“Builds” is the term given to those fancy ways to introduce text or other items to the screen (e.g. text
flies in from the left, one letter is added at a time from the right, etc.). Strictly limit the use of builds or
do not use them at all. If used, stick to the simple ones. Regular conference attendees have seen them
all and are not impressed. They also distract from your message. “Dimming” is the term given to the
dulling (or the disappearance of text or objects once the next item has been introduced). Many
conference attendees have a short attention span, take notes, or look elsewhere momentarily. You do
not want them to return to viewing the screen and realize that they missed information. If it is
important enough to be included on your slide in the first place, do not dim it.
5. Do not rely on the spell checker
Pubic safety is not the same as public safety. Form instead of from, or policy instead of police, are
other common mistakes. Also check your grammar and punctuation. Be consistent with punctuation.
Periods, for example, should be present or absent from text on all slides or none of them.
6. Number your slides
This allows people to take notes or ask questions that reference specific slides. If necessary, you can
then return to the slide easily for discussion.
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7. Exclude technical detail
The presentation should be a short, impressive summary of your work. If you must include technical
detail, give a handout afterwards or point the audience to your most recent book/article/publication.
If you anticipate technical questions, consider adding this information in slides at the end of the PPT
that you can show only in support of your (short) answer to specific questions. The audience expects
you to talk about the content of your slides. Skipping through slides because you are running out of
time appears very unprofessional.
8. Continuity across slides
Good presentations maintain a style throughout. Decide on a color scheme and one or two fonts,
formats and text sizes (Title vs. heading text, for example) and stick to them. Maintain consistent
margins. Be consistent with punctuation.
9. Finish on your title slide or black screen
When you finish talking let the audience see your title slide with your contact details or end on a
black screen so that they can concentrate on your message and how good you are. Do not end the
presentation by returning to the software application and let them see the slide layout view.
10. Arrive early to set up
Before the audience is in the room, get your PowerPoint presentation ready and cued. Do not let the
audience see that you don’t know how to run Windows or which folder has the presentation. Decide
on which side of the room/projector you are going to stand and try to stay there. Do not wander in
front of the projector. Finally, have a backup plan for when things go wrong. At the very least, take a
copy of your presentation on a CD or flash drive, bring a hardȬcopy print out, and email it to yourself
as an attachment. Be prepared for technical difficulties and for systems to fail.
11. Eye contact
Share your eye contact around and do not stay too long on any individual. Make sure you do not
single out any group or individual (that can be freaky!). If you take a question, respond to the person
who asked, but after a few seconds open your answer (i.e. eye contact) out to the whole room. When
using a laser pointer, avoid pointing and talking to the screen for protracted lengths of time.
12. Be prepared and appear confident
First impressions count. The first few seconds of your presentation are vital to captivate your
audience. Stand tall and start with a smile, but then move to a more serious expression when you
begin to talk. Even if you do not have confidence in yourself, act like you do! Remember, you know
your own material better than anyone else. Dress well but not too flashy. Never say that you just
finished the presentation a few minutes ago. It suggests that the presentation—and the audience—is
not important enough to devote more time to.
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Base Maps

Data are essential to GIS and base maps are the foundation. Essentially, base maps are your reference
layers for orienting and analyzing your primary study data. Typically, they comprise a street
centerline and a geographic backdrop such as a census tract, ZIP Code, and/or county boundary.
Street centerlines of almost every city, state, or region can be downloaded free from the Internet (see
“FREE GIS Data Sources” section).
City planning departments also have GIS data (such as updated street files) that they may be willing
to share. You can also integrate data from other sources, such as criminal justice data or health and
social services data. Remember, you want to obtain “shapefiles” if possible, which are the most
compatible forms of data for use in a GIS. If shapefiles are not already available that’s OK, you can
create them. But, the data—whether it is your own or from another agency—must have a geographic
reference such as street addresses or XY coordinates that can be used to link it to a map.
Examples of criminal justice data include:

x
x
x

Number of crime incidents
Types of crime incidents
Locations of police stations, substations,
and patrols

x
x
x
x
x
x
x

ComputerȬaided dispatch calls

x

Number of protective/restraining orders

Firearms purchases
Locations of prisons and jails
Locations of criminal and juvenile courts
OpenȬair drug markets
Gang locations
Jurisdictional lines for state police, county
sheriffs, tribal police, and municipal police

Examples of health, social & environmental
data include:

x
x
x
x
x
x
x
x
x
x
x

Locations of public assistance agencies
Locations of public housing
Locations of hospitals & emergency rooms
Locations of mental health programs
Locations of youth shelters
Census data
Neighborhood boundaries
State and county boundaries
Business locations
Transportation routes
Park and recreation areas

FREE GIS Data Sources

x
x
x
x
x
x
x
x

Criminal Justice Web Sites | http://www.icpsr.umich.edu/NACJD/links.html#crime.
National Archive of Criminal Justice Data | http://www.icpsr.umich.edu/NACJD/gis
New Jersey Department of Environmental Protection | www.nj.gov/dep/gis/lists.html
State of Florida Shapefiles | http://www.fgdl.org
State of Massachusetts Shapefiles | http://www.mass.gov/mgis/laylist.htm
Geography Network | http://geographynetwork.com/data/downloadable.html
Census TIGER/Line® Data | http://arcdata.esri.com/data/tiger2000/tiger_download.cfm
Geospatial One Stop | http://www.geodata.gov

Also contact local government agencies and NGOs, and Google keywords such as “GIS data”
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Aerial Photographs and Orthophotography

Aerial photography refers to photographs of the ground
taken from an elevated position. Some of the first aerial
imagery of the Earth was drawings done from hot air
balloons. Today, there are much more sophisticated means
of acquiring images of environments, such as with aircraftȬ
mounted gyroȬstabilized digital cameras. If you ever used
Google® Earth, or clicked the “Aerial” button when viewing
Bing™ Maps, then you have seen aerial photographs.
Digital
orthophotography
combines
the
image
Source: NJ DEP
characteristics of a photograph with the geometric qualities
of a map. This is done through a process which converts a digitized perspective aerial photograph to
a digital product that has been rectified for camera lens distortion, vertical displacement caused by
terrain relief and variations in aircraft altitude and orientation. Digital images such as aerial
photographs or orthophotos can be added to ArcMap as a layer—in the same manner as you would
add a shapefile. These layers can serve a variety of purposes such as a reference tool for revision of
street networks or as a backdrop that provides additional environmental context to shapefile features
layered on top. Some state agencies (such as NJ DEP) provide aerial photographs to the public via
free internet download. You can also add Google® Earth satellite (or other digital) imagery into
ArcMap. NOTE: Georectifying the images in ArcMap may be necessary.

Examining Metadata

From ArcMap’s Table of Contents, rightȬclick layer > Data > View Metadata
Metadata is data about data. In ArcGIS, it is
information about shapefiles and other
spatial data. It is a separate document
(usually in XML format) that communicates
the basic characteristics of a data or
information resource. It represents the who,
what, when, where, why and how of the
resource19. In ArcGIS Desktop, ArcCatalog
is used to create metadata. When creating
metadata, much of the information must be entered
manually.
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ZOOM IN: Police Officers’ Perceptions of Maps and Aerial Photos

Adapted or excerpted directly from: Canter, P. & Harries, K. (2004).Police officers’ perceptions of maps and aerial photographs. Journal of
Police Science and Management, 6(1), 37Ȭ50.

With the increasing adoption of geographic information systems (GIS) by police departments and
other law enforcement agencies around the world, the issue of how effectively maps and related
media communicate information has become germane. Canter and Harries surveyed a small sample
of police officers in order to test the utility of alternative visualizations of crime data presented at
varying geographic scales. Their ultimate objective was to enhance understanding of the effectiveness
of maps and aerial photographs commonly used in the context of various investigative, community,
managerial, and other applications of GIS tools.
With due caution for the unrepresentative and small sample size that was used, their findings should
at least be considered when designing maps for police personnel. The study highlights the
importance of understanding your audience(s) and, thus, making finished maps that will effectively
communicate findings. Even when presenting results from the same GIS analysis to different groups
of people (i.e. policyȬmakers, police officers, academics), remember that you should (re)design and
present your maps to each unique group as appropriate. The following are generalized findings:
1.

The interpretation and use of largeȬscale crime maps can be improved when aerial photography
and building footprints are introduced to the display. As a group, officers favored a combination
map to view crime at the neighborhood scale.

2.

Officers were able to relate the location of a crime incident to other map features such as
buildings, wooded areas, and parking lots. Several officers commented on the utility of aerial
photographs and building footprints to identify possible ingress/egress points or offender travel
paths. Officers noted the location of auto theft locations within parking lots, which they were
unable to do using centerline maps.

3.

Officers generally believed that aerial photographs and building footprints improved their ability
to read and interpret a crime map.

4.

Centerline maps tended to be more useful when displayed at an intermediate or community
scale. Unlike the neighborhood scale crime map, officers tended to dislike the introduction of
building footprints to a communityȬscaled centerline map.

5.

Aerial photographs improved the visualization of mapped crime data, particularly when
displayed at a large scale. The utility of neighborhood centerline maps for showing the location of
crime improved when building footprints and aerial photographs were added to the view.
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Downloading Census Shapefiles
1.

Download a census geography (i.e. tract or block group) shapefile for one county at a time from
any part of the country. You can do this from the ESRI TIGER site
http://www.esri.com/data/download/census2000_tigerline or from the census website
http://www.census.gov/geo/www/cob/bdy_files.html

2.

Define that shapefile as geographic, NAD 1983 (because it is unprojected).

3.

Project that shapefile into the appropriate state plane (or your best guess).

4.

You can download SF1 (shortȬform) data from the ESRI site for tracts, block groups, or blocks,
but this only includes basic age, sex, race, household composition and own/rent data, so you
will likely need to download SF3 (longȬform) census data from the US Census Bureau site.
Diagram illustrating the legal and
statistical entities for which the
Census Bureau tabulates data during
the decennial census.
(Source: U.S. Census Bureau,
Geography Division. Created: January
17, 2002.)
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Map Projections

Projections manage the distortion that is inevitable when a (mostly) spherical earth is viewed as a flat
map. All projection systems distort geography in some way— either by distorting area, shape,
distance, direction, or scale. There are dozens of different projection systems in use since different
systems work best in different parts of the Earth and, even within the same parts of the Earth, GIS
users have different priorities and needs. The tools for working with projections in ArcGIS are
relatively advanced particularly in their ability to reȬproject layers with different projection systems
“on the fly.”

Recognizing the Coordinate System

From ArcMap, rightȬclick the layer > Properties > “Source” tab ȬorȬ From ArcCatalog, rightȬclick the
shapefile > Properties > XY Coordinate System” tab.
Map layers can be drawn according to a geographic coordinate
system or projected coordinate system. Geographic coordinate
systems indicate location using longitude and latitude based on a
sphere (or spheroid) while projected coordinate systems use X and
Y based on a plane. As long as computer screens and printed maps
are flat, projected coordinate systems will be more appropriate for
working with GIS data. Often you will not know the coordinate
system used, particularly if you inherit data or download it from
the Internet. If you are lucky, the shapefile will include a .proj file
which contains information about the coordinate system. If there is
no projection information, you can map the data to determine its coordinate system. If the map units
displayed in the gray bar below your map are in degrees, seconds, and minutes, then you know the
data are in a geographic coordinate system. You may also recognize this because your maps look
distorted. For example, when Philadelphia map layers are in a geographic coordinate system, the
image appears to be sagging to the east. Map layers in geographic coordinate systems are sometimes
described as “unprojected.” Map layers downloaded from the US Census Bureau are generally in this
format.

Projecting Unprojected Shapefiles

From ArcCatalog, rightȬclick the shapefile > Properties > XY Coordinate System” tab > “Select” button
ȬorȬ From ArcToolbox > Data Management Tools > Projections and Transformations > “Define
Projection” tool
In most cases you will want to convert unprojected map layers—those with a geographic coordinate
system—to projected map layers. There are two steps involved in this process. First, you must create
a .proj file “defining” the map layer as unprojected; then you can “project” the map layer using the
projection of your choice. NOTE: If you are projecting a raster image, use the “Project Raster” tool under
“Raster” (also within the “Projections and Transformations” toolbox).
In the “Define Projection” tool’s dialog box, choose a dataset (i.e.
shapefile) as the input. If you added the relevant map layer to ArcMap,
you will be able to find it in the dropdown menu. Otherwise you will
need to click on the “folder icon” button to locate your map layer.
Then you can choose the coordinate system using the

button.
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From the “Spatial Reference Properties” dialog box, click the
“Select” button on the Spatial Reference Properties, then choose
“Geographic Coordinate Systems,” “North America,” and “NAD
1983 Datum.” Click the “Add” button, then click “OK” on the
Spatial Reference Properties
dialog, then “OK” on the
“Define Projection” tool.
You should not notice a
difference in how the map
layer is drawn as a result of
defining
the
coordinate
system. As a result of defining it, there is now a .proj file
associated with your map layer and you can look at the detailed
spatial reference information. Before you define a layer as
unprojected, ArcGIS will refer to it as “assumed geographic.”
In order to project the map layer, open the “Define Projection”
tool again. Click on the
button to the right of “Output Coordinate System” to choose your
projection. Click on the “Select” button on the “Spatial Reference Properties” dialog box, then choose
“Projected Coordinate Systems.” Now you need to choose your projection. For relatively small areas
like Philadelphia, the differences in projection systems (the distortion in shape, area, distance,
direction, and scale) are minimal. You are best choosing whatever projection system is most
commonly used. In Philadelphia, that is State Plane 1983 (feet) Pennsylvania South. After making
your selection, click “OK.” ArcGIS may indicate that there is a “Datum conflict between map and
output.” In order to map your newly projected layer, create a new ArcMap document.

Working with Projected Map Layers

Sometimes the map layers you receive will already be projected but won’t carry a .proj file so you
don’t know the projection. If you download the data, be sure to read any metadata files that may
contain information about the project. If someone has sent you the map layers, ask them about the
projection. If these approaches fail, try mapping the data. You may recognize that the data are
projected by the units showing in the gray bar below the map. If they are not in longitude and
latitude, they are probably projected. As you work with a particular projection system, you will come
to recognize the map units and range of coordinate values. For example, State Plane coordinates for
Philadelphia are generally in feet and look like 2691607.78, 246268.98. UTM coordinates will be in
meters and look like 486850.72, 4430095.19.
When you add a shapefile to ArcMap that the software recognizes as being projected but has no .proj
file, ArcMap will usually warn you that spatial reference information is missing. Data that are
projected but missing spatial reference information will look fine when they are drawn, but you may
not be able to use ArcMap’s “on the fly” projection capabilities, measurement tools, spatial join, or
geoprocessing functions.
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If you know the proper projection, you can use the “Define Projection” tool in ArcToolbox. You will
need to select the projection from the “Projected Coordinate Systems.” If a map layer is already
projected AND defined, you can change the projection using the same tool. NOTE: You must add the
reȬprojected shapefile to a new ArcMap document to see the results.

Troubleshooting with Projections

If you are unable to draw your map layers together or if your distance units do not make sense, you
are likely experiencing a problem with projections. If you are not able to figure out the problem, you
may want to show your shapefiles to someone with more GIS experience. It is easy to get confused
while using the “Define Projection” and “Project” wizards, and frequently the more you try to fix the
problem, the more mixed up your projections get. Stay calm and don’t be ashamed to ask for help.
You may also have luck returning to your original files (be sure to keep a copy of the originals before
messing with the projection).

Defining Projection for a Data Frame

From ArcMap’s Table of Contents, rightȬclick on the
Data Frame > Properties > “Coordinate System” tab
Ideally, you will know and will specify the projection
of each of your map layers. Alternatively, you can set
the projection for your Data Frame for your map
document. All of the map layers listed under the
Layers icon in your table of contents are in the same
data frame (you can have multiple data frames in the
same map document, although in most cases you will
probably have just one). NOTE: The Data Frame will
automatically assume the Geographic or Projected
Coordinate System of the first shapefile that is added to
ArcMap. If subsequent shapefiles are unprojected, or in a
different coordinate system than the data frame, ArcMap
may notify you to this effect prior to (temporarily) reȬ
projecting the shapefile onȬtheȬfly.
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Creating New Shapefiles from Existing Shapefiles

From ArcMap’s Table of Contents, rightȬclick layer > Data > Export Data
This makes a separate duplicate shapefile. It works like a “save as”. In the “Export Data” dialog box,
give your new file a name and location. The resulting shapefile will have the exact same features and
variables in the attribute table as the original shapefile.
You can create a new shapefile that
only includes your selected map
features by rightȬclicking on its
layer name in the Table of
Contents > Data > Export Data.
Choose the appropriate radio
button
regarding
coordinate
systems (you’ll probably want the
default). Make sure you have
“Selected features” chosen in the
“Export” drop down box. Select a location and name for
the output shapefile and then click the “OK” button.
Data Frame projections are temporary, shapefile
projections are (or should be) permanent. However, if you want to quickly and permanently project
an unprojected shapefile that is within a Data Frame of the desired Projected Coordinate System, then
the “Export Data” function is a good method. In the “Export Data” dialog box, under “Use the same
coordinate system as:”, select the radio button next to “the data frame.” This will automatically create
a new shapefile that will be permanently projected with the same coordinate system as the Data
Frame.

Using Excel Spreadsheet Files

ArcGIS 9.3 is the first version that does not require Excel spreadsheets to be converted to DBF format
prior to importation. Though, some preparatory work is still recommended. The name of the Excel
file that will appear in the Table of Contents in ArcMap is the name of the Worksheet (i.e. those 3 tabs
at the bottom of the screen that read “Sheet1”, “Sheet2”, “Sheet3”, and appear by default when you
open a new spreadsheet). Therefore, you should change the name of the Excel “Worksheet Tab” that
you will import to something meaningful (When you add the Excel Spreadsheet file to ArcMap, it
will prompt you to choose to one of the Worksheets). Since ArcGIS only permits 10 characters or less
as attribute table column headings, you should change the column names in the Excel Worksheet to
be 10 or fewer characters, with no spaces, to prevent undesired truncation.

Converting Files to .DBF

Although ArcGIS imports Excel files directly from .XLS format, it still creates and exports attribute
tables as DBF files. That is, DBF is still the primary and preferred format. So it is good to know how
to convert files to DBF should the need ever arise. You can use Excel, SPSS, ACCESS, or other
statistical and database packages. In many cases, Excel will be the only software available for the job.
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Excel can open a wide variety of formats, including delimited or fixed width text, Lotus, Quattro Pro,
and web pages. If you are working with one of these other formats and need to make changes to your
data in Excel, it is probably best to save the document as an Excel worksheet. When you save an Excel
document, you can choose another format using the “save as” options. But even if you choose .dbf at
this stage, you may encounter problems. For example, your new .dbf file may not include all of the
cells in your original file, or the columns may be formatted as strings rather than numbers. Here are
some things you can do to increase the odds of preserving your data during the conversion.
1.

Limit your column headings to 10 characters. Excel will let you
have infinitely long column names, but ArcGIS will shrink them.
It’s better to come up with your own abbreviated names than to
risk losing important information when ArcGIS truncates the
names.

2.

Check your columns to be sure that they are formatted correctly as
strings (left justified) or numbers (right justified). Also, look for
rows at the very top that may be blank or contain data that are
different from the following cells. For example, you may have a
column named “programs” with values ranging from 2Ȭ10 for all of
your cells, but the first cell is blank or has an “NR” for “not
reported.” This column will be formatted as a string when you
convert to .dbf and open it in ArcMap—because .dbf takes its cue
from the first data cell in the column. To avoid this problem, you can resort the data so that the
blank cell is not on top, or you can put in an appropriate numeric value (such as 0 or 999 for
missing data). You can convert a string field to numeric in ArcMap, but it’s easier if you start
with the right format.

3.

When you are ready to save your data, highlight all of the cells that contain values (including the
column names). From the Insert menu, go to “Name” and “Define.” Type in a name (type
anything; it doesn’t matter), click “Add” and “OK.” This increases the likelihood that all of your
cells will be included in the new table. Now you can save your document. First, save all changes
in your Excel document. Then, from the File menu, choose “Save As” and select “DBF4” from the
dropdown menu. First Excel will give you a warning that the .dbf format doesn’t support
multiple worksheets and that only the data in the top (active) worksheet will be saved. Click
“OK.”
Excel will then give you a second warning
message because .dbf is very different
from .xls and some formatting may be
lost. Just click “OK.”
If you don’t get BOTH of these warnings,
then the conversion to DBF was not
successful. Try it again by copying
everything into a new workbook.
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When you close Excel, Excel will prompt you again with these messages, as though it is still
incredulous that you would choose any format other than Microsoft’s. Humor the software and go
through these two steps again. As soon as you add your table to ArcMap, look it over to make sure
that all of the data came through and are in the right format.
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GIS Data Format and Data Cleaning

GIS mapping follows the time tested theorem “garbage in, garbage out”. If your addresses are not
clean, then you are significantly increasing the probability that they will not be geocoded correctly.
Address information should comprise 4 fields: Street Address, City, State, and ZIP code (last 4 digits
of a ZIP should be in a separate field).
“Correct”
Record
1

Address
677 Huntington Ave

City
Boston

State
MA

ZIP
02115

“Incorrect”
Record
Address
1
677 Huntington Ave, Boston, MA 02115
Cleaning addresses means:
x Retaining only the key address elements in one field: house/building number; street name; street
type (e.g., 100 Main St)
x Getting rid of all extraneous characters (e.g., “BSMT” “REAR” “APT 1” “UNIT 3”, etc.)
x Standardizing spelling (e.g., converting all incidences of “Mass Ave” to “Massachusetts Ave”)
x Removing all irrelevant punctuation including commas, quotation marks, apostrophes,
parentheses, dashes, etc. that may interfere with the application’s coding and can cause an error.
(Periods are not needed after abbreviations, such as street types).
x Changing street address ranges (e.g. “110Ȭ114 Main St”) to only one number (e.g. “110 Main St”)
x Finding appropriate street addresses for building or location names (e.g. “Wynnwood
Apartments”, “Homeless Shelter”)
x Standardizing cross streets (e.g. use ampersand [&])
Some examples:
Record #
1
2
3
4
5
6
7
8

Original Address
677 Huntington, #304
46 Burr REAR
Unit B, 1200 Comm Ave.
423 Allston St., 4th Floor, Suite 100
The Landmark Building, 401 Park Drive
99 ½ Chauncey St
111Ȭ113 Walnut Street
Main St and Chestnut Ave

“Cleaned”
677 Huntington
46 Burr St
1200 Commonwealth Ave
423 Allston St
401 Park Drive
99 Chauncey St
111 Walnut Street
Main St & Chestnut Ave

XȬY coordinates should comprise two separate fields. Do not round the numbers.
For example:
Record
X
1
2672973.889167
Record
1

X
Ȭ75.238221

Y
222351.750051

Provider
Safe Meadows Healthcare Center

Y
39.916205

Provider
Safe Meadows Healthcare Center
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GISȬFriendly Datasets
x

Must have spatial location
o i.e. Street address, ZIP code, State, Tract, XY
Must have a unique ID number

x
x

Can include any other variables about each observation. Different variables should be in separate
columns.

x

Column/heading names must be 10 or fewer characters; No spaces.

ID

Location

Variable1

Variable2

Variable3

0001

123 Main St

Medical

Male

Refusal

0002

33rd St & Park Pl

Trauma

Female

Transport

0003

227 Penn Ave

Trauma

Male

Transport

Philadelphia
philadelphia
PHILADELPHIA
philly
Phila
City of Brotherly Love

Data is taken literally in a GIS, so differences in spacing, case, or coding can
cause problems. Each field in the example to the left is different as far as
ArcGIS is concerned, even though they all refer to the City of Philadelphia.
ArcGIS differentiates data by the type of information entered into each field
of a table. Data can be numerical (i.e., 19104) or string (i.e. Pennsylvania).
The ZIP code 19104 entered as numerical is not the same as 19104 entered as a
string. Think ahead about the format your data should take. Your decision
might be dependant on the type of analyzes or outputs you want to produce.
Numbers, for example, can be added or subtracted while text strings cannot.
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Geocoding20

Geocoding refers to the process of transforming street addresses into map features. In order to
geocode, you need to have a table with addresses and a shapefile for streets that matches the
geographic extent of your addresses. Through the geocoding process, ArcGIS will create a new point
shapefile by matching each street name and number in your table to a place along a line segment in
your street shapefile that represents a certain range of house numbers. NOTE: For a more detailed
discussion of geocoding, see the COPS Publication entitled “Geocoding in Law Enforcement [Final Report]”
(2000). Available at www.cops.usdoj.gov/files/RIC/Publications/geocodinginlawenforcementfinalreport.pdf

1. Preparing Tabular Data

In order to geocode you need a table (.xls, .dbf
or commaȬdelimited .txt) that has a field with
street addresses. If the parts of the address—
house number, street direction, street name,
and designation/type—are in separate fields,
you will need to collapse these into a single
field. Having a separate field with the ZIP code
can also be helpful.

2. Creating an Address Locator

From ArcCatalog, rightȬclick folder where you want to store the Address Locator > New > Address
Locator

From the “Create New Address Loca…” dialog box, scroll down the list of Address Locators, then
locate and click the “US Streets”. Click OK.
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The US Streets address locator style is used for the
majority of common United States street
addresses. Several things should be considered
when choosing an address locator style, including
the type of geometry in your reference data and
the format of address data you wish to search.
“US Streets with Zone” is another common
alternative. First, it zeros in on a specific ZIP code
area, and then finds an address on a specific side
of a street within that ZIP. This is useful when
your
study
area
encompasses
multiple
jurisdictions that have the same street names. For
example, if my study area is Essex County, NJ,
“Main Street” might be the same name of different roads in the neighboring cities of Newark and
Irvington. “US Streets with Zone” would ensure that the geocoded point is placed at the address in
the correct city (i.e. the address in the correct ZIP code area).
From the “New US Streets (or US Streets with Zone) Address
Locator” dialog box, you need to define the properties associated
with the US Streets Address Locator. Reference Data is a
shapefile that includes information about all of the streets in
your area. A street centerline shapefile is made up of line
segments that represent certain ranges of house numbers. The
line segments also contain information in their attribute table about which side has even and odd
house numbers. Where it says “Reference Data”, click the button with the “folder icon” to browse to
your streets shapefile and click “Add” button. In the “Fields” section below, ArcGIS may be able to
identify the appropriate fields on its own. If no field names appear in the drop down menus, or if
they do not look right to you, you’ll need to identify them yourself.
The “Input Address Fields” section allows you to identify the names for the field(s) in your tabular
data that contain the street address information. The “Matching Options” section allow you to
indicate the level of sensitivity for the matching process. Essentially, ArcGIS needs to match the
house numbers and street names in your tabular data with information in the street shapefile’s
attribute table (reference data). If the spelling of the street name is slightly different or an appropriate
range of house numbers cannot be located, ArcGIS will assign the match a less than perfect score (100
is a perfect match). ArcGIS can geocode based on street intersections in addition to specific house
numbers. In the “Intersections” section you can identify symbols (or “AND”) used in your tabular
data to indicate intersections. The “Side Offset” option allows you to place points slightly away from
the middle of the street centerline file. While ArcGIS will know what side of the street your address
falls on, your points will appear to fall directly on the centerline unless you specify an offset (e.g. 15Ȭ
20 feet is usually adequate).
If you check “X and Y coordinates” under the “Output Fields” section, ArcGIS will add X and Y fields
to the new (geocoded) point shapefile’s attribute table. Once you click “OK,” a new address locator
will be created. Once you create an address locator, you do not need to do it again (unless you go to a
new computer).
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3. Geocoding Addresses

From ArcMap, Tools > Geocoding > Geocode Addresses
NOTE: You do not need to have your street shapefile (reference data)
added to your map document.
In the “Choose an Address Locator” dialog box, select the
appropriate Address Locator or, if necessary, click the “Add”
button and navigate to the folder where the “Address Locator”
is located. After finding your address locator, click “Add,” then click “OK.”

On the next screen (“Geocode Addresses:” dialog box), you need
to select the tabular file with the addresses you want to geocode.
Then select the field in the table that contains the street address;
choose a name and location for the new point shapefile that will be created (output). The “Geocoding
Options” button gives you access to many of the same options available
when you create an address locator. When you click “OK,” ArcMap begins
the geocoding process. The next screen indicates how well ArcGIS was
able to match the addresses. When you click the “Close” button, a new
point shapefile should appear in the Table of Contents.
If you open the attribute table associated with the shapefile, you will see that the geocoding process
added several fields to your original address table. The “Status” field indicates whether the record
was matched (M) or left unmatched (U). The “Score” field indicates how closely the record matched
the street centerline file. The “Side” field indicates on which side of the street the address was
matched. The “Arc_Street” field is the address used in the match. This will be the same as the original
address unless you edit it during the “Interactive Review.”

4. Interactive Review and Rematching Addresses

Click the “Rematch” button from the “Geocoding Addresses” Results dialog box ȬorȬ From ArcMap
> Tools > Geocoding > Review/Rematch Addresses > choose the layer name of the Geocoding Result
ȬorȬ RightȬclick on the geocoded layer in the Table of Contents > Data > Review/Rematch Addresses
You will need to start an edit session in order to proceed with the Interactive Rematch process. The
interactive review process can be used to correct and then match the unmatched or poorly matched
records. If you have thousands of addresses in your address table, you may not be able to review all
of the unmatched records. But for smaller data sets it is very important to review the unmatched
records.
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From the “Interactive Rematch” dialog box, you
can edit the addresses in order to get a
match/better match (don’t worry, this only
changes the address that ArcGIS uses for
geocoding; it does not change the data in your
original table of addresses). Before you begin
reviewing addresses, click the “Show results”
dropȬdown menu to display only the addresses
you are interested in reviewing. For instance,
rather than scrolling through all the Matched or Tied addresses, you might only be interested in
reviewing the “Unmatched” addresses.
To edit an address, simply click in the “Street or Intersection” text box and make the changes, then hit
the “Search” button. ArcGIS will list possible matches. Highlight the best candidate and click the
“Match” button. Street intersections are the most likely to create ties in the matching process. For
example, ArcGIS might not know whether to place the “10th and Market” point on 10th Street or just
north or just south of Market Street. Most likely, it will not matter for your work. If it does, you are
better off using a house number and street, rather than an intersection. Choosing the “match if
candidates tie” box in the geocoding options will help you avoid having to match these individually.

Determining an Acceptable Match Rate

A minimum reliable geocoding match rate is 85 percent21. Be sure to write down the match rate so
that you can report it later. Often you will receive a list of addresses that contains some PO Box
numbers or missing data that will prevent you from matching all your records. Other times your
addresses will look fine but simply won’t match the street centerline file. The most important thing to
determine is if the error (the unmatched records) is random or systematic. If you have done all that
you can to gather complete and accurate addresses, random error is acceptable and probably
unavoidable. Systematic error is not. Be sure to check for patterns in your unmatched records (either
by interactively reviewing unmatched records or, after finishing geocoding, open the attribute table
and sort by “status” to review all the “U” (unmatched) records. There is no guarantee that the
matched records will be mapped in the right place. Check with the “Identify” tool to make sure that
records were mapped somewhere that makes sense to you.

Locating an Individual Address

Edit > Find > “Addresses” tab
If you have only an address or two to map, you can take a shortcut.
From the “Addresses” tab of the “Find” dialog box, choose an
address locator in the drop down menu. If you have not already
created an address locator, you will need to do so. Next, type the
address in the “Street or Intersection” text box and click the “Find”
button. ArcGIS will display the possible matches below, with their
score. Right click on one of the addresses for mapping options. You
might choose to “Flash” candidate locations to make sure ArcGIS is
mapping in the right area or “Add Point” if you want a marker at the location. Keep in mind that this
is only a graphic; it can easily be deleted or moved. You can change the size and color of the graphic,
but you cannot turn it on and off like a map layer. It has no attributes associated with it.
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Creating XY Coordinates from Addresses

When creating an Address Locator, or from the “Geocoding
Options” button, check the “add xȬy coordinates” box

Displaying XY Data

From ArcMap, Tools > Add XY Data
Sometimes you will need to map a table that just has X and Y
coordinates identifying specific locations but no shapefile associated
with it. This might occur because a GPS (global positioning system)
unit was used to collect the data or because that is the way a private
vendor has chosen to distribute the data. A table with X and Y
coordinates is much easier to distribute than a shapefile, because it is
smaller, does not involve multiple files, and is not ArcGISȬspecific.
In order to map the data in ArcGIS, the X and Y values will need to
be included as separate columns in an Excel, dBASE or delimited
text file. You can add the table to ArcMap just as you would a
shapefile (with the “Add Data” button), but you do not need to add
it to ArcMap in order to map it.
From the “Add XY Data” dialog box, browse to the table with the
XY data. ArcMap will probably find the appropriate fields in your
table; otherwise, use the dropdown menus to indicate the fields
containing the X and Y values and click “ok.” As with shapefiles, tables with XY data that you
acquire may be projected. If the Spatial Reference “Description:” box reads “Unknown Coordinate
System, then they are unprojected.

Adding XY Coordinates to Points, Lines or Polygons (Centroids)

From the shapefile’s attribute table, rightȬclick the column name > Calculate Geometry
Just as you may need to convert a table with XY data into a map layer, you may need to add XY
coordinates to an existing layer containing points, lines or polygons. With your attribute table open,
go to options, add new field called “X,” type “Double.” Right click at the top of your new column and
go to “Calculate Geometry.” A message might appear
warning that you are about to calculate outside of an edit
session. Acknowledge this by clicking the “OK” button.
In the “Calculate Geometry” dialog box, select “X
Coordinate of Point (or Centroid, if it’s a polygon shapefile)”
from the Property dropȬdown box. Click OK. ArcMap will
calculate the xȬcoordinate for each point in the shapefile.
Repeat the above steps to calculate the yȬcoordinate in a new
field named “Y”. You can check the new XY coordinates by
mapping them. With your table open, click on “Options,” and go to “Export.” Choose “yes” and add
the new table to your existing map; then close the table. From the tools menu, go to “Add XY Data”
and select your table from the drop down menu (ArcMap will probably have done this for you
already). Click “OK.” Your table of contents should now show two identical point layers.
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Joining Tables

From ArcMap’s Table of Contents, rightȬclick the layer > Joins and Relates > Join
Often you will have attributes stored in a separate table that you will need to join to a shapefile in
order to display that data. This is especially common with census data, when you will often obtain
census attribute data (SF1 or SF3) in files separate from the shapefiles for census tracts, blockgroups
or other unit of analysis. Tables to be joined with shapefiles must be in either the DBF or Excel file
format.

1. Identifying a Key

In order to join an attribute table to a shapefile, you must identify a field that is common to your
attribute table and the attribute table associated with your shapefile. This field is known as a key, or
unique identifier, because it uniquely identifies each record in your table and shapefile on which
ArcGIS can join, or match, your data. The values must be formatted in an identical way (i.e.
numerical, string). If they are not, you must edit one of the fields or create a new field and recalculate
the values so that their formats match perfectly.
At left, the attribute
table of a census tract
shapefile
contains
multiple fields that
uniquely
identify
each
record
(e.g.
STFID)

The table to the right includes
several attributes of census
tracts but cannot be mapped
until it is joined to a shapefile.
There is one field that uniquely
identifies records AND can be
used to match fields in the
census tract shapefile: STFID.
The field name doesn’t have to
be the same in the attribute
table and the shapefile in order to join them; they just have to be formatted in the same way. While
you may perform joins on census data most frequently, you can join attributes to shapefiles for other
data: zipcodes, councilmanic districts, counties. You can join on a name (such as neighborhood name,
or the name of an institution), although keep in mind that differences in spelling and spacing will
prevent records from joining.
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2. Joining a Table

To join attribute data to a shapefile, you must add the shapefile to ArcMap. RightȬclick the shapefile
layer in the Table of Contents > Joins and Relates > Join. From the “Join Data” dialog box, select “Join
attributes from a table” from the first drop down menu, under where it reads “What do you want to
join to this layer?”. In the drop down menu under item 1, select the key field in your shapefile. In the
drop down menu under item 2, select the table you wish to join to the shapefile (the table does not
need to be added to ArcMap first). In the drop down menu under item 3, select the key field in your
table (from item 2) that you wish to join.

Keep in mind that ArcMap does not check to make sure that
the key fields or their formats match, so you should doubleȬ
check them (by opening both tables) before performing the
join.
Under the “Join Options” section, indicate what you want ArcMap to do if all of the map features in
the shapefile do not have a match in the attribute table, or vice versa. The default is to “Keep all
records”, meaning that some map features might have no values for some fields. (Individual records
might not match because of problems with the key or because there are different numbers of records
in each of your files). When you open your shapefile’s attribute table after a successful join, there
should be new fields that contain the data from your table. The new field names will include the
name of the attribute table from which it came.
When you perform an attribute join the data is dynamically joined together. This means that nothing
is written to disk and the join holding the data together is not permanent. To make the join
permanent, rightȬclick on the shapefile layer in the Table of Contents > Data > Export Data”. This
works like a “save as,” so it creates a new shapefile. The resulting shapefile will have variable names
that are much shorter than those in the table created during the temporary join, and it will include
attributes from both (or all) joined tables. NOTE: Several tables or layers can be joined to a single table or
layer and relationship class joins can be mixed with attribute joins.

Removing Joins

From ArcMap’s Table of Contents, rightȬclick the layer > Joins and Relates > Remove Join(s)
When a join is removed, all data from tables that were joined after it are also removed, but data from
previously joined tables remain. Symbology or labeling that is based on an appended column is
returned to a default state when the join is removed.
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Spatial Joins

From ArcMap’s Table of Contents, rightȬclick the layer > Joins and Relates > Join
Tabular joins use a common unique identifier to attach an attribute table to a shapefile. Spatial joins
use common geography to append fields from one layer, or information about a layer, to another
layer. This allows you to assign the characteristics of an area—such as a census tract or city council
district—to individual houses, individuals, or events as well as to aggregate points by areas.

Assigning Area Characteristics to Points

Using a spatial join, you can identify into what area a point
falls. For example, you might need to determine in what
census tract each of your study participants lives. You must
have a point theme and a polygon theme in ArcMap in
order to do this. In the first dropdown menu of the “Join
Data” dialog box, indicate that you want to join data to that
layer based on spatial location. In the next dropdown menu,
choose your polygon layer. Next, choose the first radio
button so that each point is given all the attributes of the
polygon it falls inside. If you have points outside your
polygon (for example, if you have a census tract map of
Philadelphia with points representing addresses in the city
and just outside it), choose the second radio button. Specify
the name and location of the new point shapefile that will be
created and click “OK.” The resulting point shapefile will
have as many new columns as your polygon shapefile. This
may include only the polygon identifier (such as the census tract number) or the identifier and
attributes.

Aggregating Points to Lines or Polygons

Using a spatial join, you can also determine how many
points fall in each polygon. For example, you might need to
determine how many mortgages were made in each city
council district. You must have a point layer and a polygon
layer in ArcMap in order to do this.
In the first dropdown menu of the “Join Data” dialog box,
indicate that you want to join data to that layer based on
spatial location. In the next dropdown menu, choose your
point layer. Next, the radio button should be set for “Each
polygon will be given a summary of the numeric attributes
of the points that fall inside it, and a count field showing
how many points fall inside it.” If your points do not all fall
within your polygons (for example, you have a map of city
council districts and points representing addresses in the
city and just outside it), choose the second radio button, instead. You can then decide if you want to
summarize the attributes of your points by their areas in the boxes below. Finally, specify the name
and location of the new area shapefile that will be created. Click “OK.”
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If you did not check any of the boxes to summarize the attributes of the points, your new shapefile
will have only one new field named “Count_”. This will indicate how many points fall into each
polygon. You will probably want to change the name to something that you will remember (by
creating a new field called “TheftCount,” for example, and calculating it as equal to “Count_”). Now
you can use this count value as the basis of a thematic map.
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Downloading & Joining Census Attribute Data
1.

2.

Go to the US Census Bureau website www.census.gov. Follow the
link for American Factfinder and then data sets (buttons on left).
Select your data set. SF3 is the census long form and contains the
most data.

Select either “detailed tables” or “custom tables” (if you want to pick
individual variables from within census tables… this is more
involved but gives you greater flexibility).
4. Choose your geography. If you want census tracts, select that from
the first dropdown menu, then choose your state and county. Be sure
to choose Ȉall census tracts.Ȉ If you want block groups, first choose the
“geo within geo” tab at the top of the page, then choose block groups
from the first dropȬdown menu. If you want all the block groups
within the county (most likely), choose “county,” then your state and
county. Be sure to choose “all block groups” at the end. Click “add”
then “next.” Be sure to let the website refresh fully after each step before you make your next
selection.
5. Choose your variables. You may find it easiest to use the “by subject” or “by keyword” tabs so
you can see the variables listed by topics of interest to you. If you used the “custom table”
option, put a check mark next to the box for each variable you want
(see below); only these will be downloaded. Be sure to include an
appropriate denominator (it will usually be listed first, as “total” as in
total people who answered this question). If you used the “detailed
tables” option, you will download all of the variables within a
particular table which will include a denominator.
6. Go the “print/download” option from the blue header to download
your data. Save as an Excel table. This will automatically transpose
the records, so each row will represent a geographic unit (such as a
census tract) and each column will represent a different variable.
(IF YOU HAVE TROUBLE DOWNLOADING DATA and are using
Microsoft Explorer, you may need to change the settings: Select Tools > Internet Options >
Security > Custom Level > Downloads > Enable automatic prompting for file downloads)
7. Unzip your files. You will only need the Excel file that ends with the word “data.”
8. Open the Excel table. Change the column names to be 10 or fewer characters, with no spaces in
the names, so you can bring this into ArcGIS. Create a data dictionary, if necessary, to
remember what each variable means. Be sure to have only one row with column names (when
you open the table, there will be two). Confirm that one of the geographic identifiers matches
the geographic identifiers in your corresponding shapefile. Save your file with these changes.
9. Add your table to ArcMap. Look at it and make sure the columns imported correctly.
10. Join the table to an appropriate shapefile. Check to make sure your join worked. Make a
permanent copy of the joined table and shapefile. Right click on the shapefile, go to data and
export, then save a new copy. Yes, do add it to the map when you are done.

3.

NOTE: You may need to calculate new values in your table in order to get the variable you want. If you use poverty, for
example, youȇll need to add three columns (income 50% or less than poverty line, 50Ȭ74%, and 75Ȭ99%) together to get the
total number of people living below the poverty line. If the data doesn’t download correctly, turn off your popȬup blocker
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Attribute Tables for Shapefiles

From ArcMap’s Table of Contents, rightȬclick layer > Open Attribute Table
Every shapefile has an attribute table associated with it. The table will have as many rows, or records,
as it does map features. The total number of records will be shown at the bottom of your table. There
can be any number of columns, or fields. Two are standard: FID (the feature ID) and Shape (which
can be point, polyline, or polygon). The rest of the fields will vary. There should be a field that
identifies each map feature with a unique name or number, such as a census tract number or
neighborhood name. There may be additional fields
identifying attributes of the map feature (type of crime at a
particular address, number of people living in a census tract).

Other Attribute Tables

Often you will have attribute data in a table separate from your shapefile. For example, you may
have a census tract shapefile with no attribute information and a table with all of the 2000 census tract
data. ArcGIS can read Excel (.xls), dBase (.dbf) and commaȬdelimited text tables (.txt), but will allow
editing for only .dbf or .xls tables (you can convert .txt tables to .dbf in EXCEL, SPSS, ACCESS, or in
ArcMap). You can add attribute tables to ArcMap just as you do shapefiles, using the “add data”
button or, from the file menu, “Add Data.” When you add a table, ArcMap will switch the table of
contents from the “display” to “source” tab. You can only see tables listed when the “source” tab is
active. Open the table by right clicking on its name in the table of contents and going to “open.”
NOTE: Your table should have at least one column that contains geographic information. This might be a street
address, X and Y coordinates, census tract number, zip code, or other identifier that will allow you to match the
information in your attribute table to map features in a shapefile.
You can work with tables—sort values, freeze columns, generate summary statistics, select records,
and export tables—without worrying about corrupting your data. You cannot change any of the data
in your table unless you go to “start editing” from the editor toolbar… except to add new fields or
delete existing fields.

Sorting Records

From the shapefile’s attribute table, rightȬclick column name > Sort
Ascending/Decending

Freezing Columns

From the shapefile’s attribute table, rightȬclick column name > Freeze/Unfreeze Column
Freezing a column means that it will remain in view even as you scroll.

Summary Statistics

From the shapefile’s attribute table, rightȬclick
column name > Statistics
You can bring up summary statistics for any
numeric field (numeric fields will be justified right).
You can obtain summary statistics on additional
fields from the “Field” drop down menu of the “Statistics” dialog box.
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Selecting Records

You can select a subset of your records to look at more
closely in a number of different ways. You can highlight
an individual record (row) by clicking in the gray area at
the far left side of the table. To highlight multiple records,
hold the control key down. At the bottom of the table,
ArcMap will indicate how many of the total records are
highlighted. Click on the “Selected” button to view only
the selected records. You can switch the selection, so that
all of the highlighted records become unȬhighlighted and all unȬhighlighted records become
highlighted. From the options menu, choose “Switch Selection.”
select all records or clear selection from the options menu.

You can also

Exporting Tables

From the shapefile’s attribute table, click the “Options” button > Export
You may need to export your table from ArcMap, because you have made changes, need to convert a
.txt table to .dbf, or for any other reason.

Add New Column/Field

From the shapefile’s attribute table, click the “Options” button > Add Field ȬorȬ From ArcToolbox >
Data Management Tools > Add Field
To create a new field, open your table in ArcMap (you can also add
fields from ArcCatalog). This can be a freeȬstanding table or one that is
associated with a map layer, but only .dbf tables can be edited. Click
on the “Options” button (if you do not see the options button, make
your table bigger; it’s in the lower right corner). Go to “Add Field.” If
this option is grayed out, you do not have permission to edit the table.
Most likely, this is because the “read only” box is checked in the table
properties. This happens automatically when you copy data from a
CD. To change this, find your table on your hard drive (through
Windows Explorer or My Computer, not through ArcCatalog), right
click, and go to “properties.” Remove the check mark next to “read only.”
From the “Add Field” dialog box, give your new field a name. Do
not use ?,&,$,#,@,*,!,~ or spaces and keep your field name to 10 or
fewer characters. From the dropdown menu, choose the type of field.
Short Integer: numeric, no decimal place, up to 19 characters Long
Integer: numeric, no decimal place, up to 19 characters Float:
numeric, with decimal place, (default is one place before decimal
and 11 after) Double: numeric, with decimal place (default is 7 places
before the decimal and 11 after) Text: numbers or letters, specify
length (default = 50 characters) Date: can include time and date Blob:
up to four characters. Finally, determine the scale (number of places)
and precision (number of places to the right of the decimal point), or
accept the defaults by leaving them 0.
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Delete Column/Field

From the shapefile’s attribute table, rightȬclick column name > Delete Field
ArcGIS will give you a warning that the deletion is permanent and not reversible. Do this with
caution. Changes will be permanent not just within your map document, but in your original file on
your hard drive, as well.

Calculating Values Outside an Edit Session

From the shapefile’s attribute table, rightȬclick column name > Field Calculator
You may find it easier to edit your attribute tables outside of ArcGIS, but ArcGIS has fairly
sophisticated tools for calculating values. In ArcMap, you can edit values in an existing field or create
a new field and calculate new values. Keep in mind that you cannot change the format (text, integer,
long integer) of an existing column, so if you need to transform the format of a column, you will need
to create a new field. ArcMap will ask you if you are sure that you want to calculate values outside an
edit session, warning that you will not be able to undo your results. Choose “Yes.”
ArcMap will bring
up
the
“Field
Calculator”
dialog
box. If your value is
a constant, you can simply type the value in the box at the
bottom. More likely, your new value will be based on values in
other fields, so you will need to use the calculator. You can
create an expression by double clicking on the field names. For
example, to calculate the percent of the population 65 and up,
click on the field name with the total 65 and up, click on the
“/” button, and click on the field name with the total
population. If you edit a table outside an edit session, it’s best
to create new fields rather than to edit values in an existing field—since you cannot undo your work.
With new fields, you can just delete a field and start over if you mess up. NOTE: If any of the records in
your table are highlighted, ArcMap will only perform calculations on the highlighted records.

Common Error when Calculating Values

ArcGIS will not allow you to divide by zero, so if the denominator (i.e. total population in the
example above) is zero for any of your records, ArcGIS will not calculate any of the values and will
display an error message. To get around this, you need to select only the records where the
denominator is something other than zero.
Start by selecting the records with a zero in the denominator (because there are fewer of these). Do
this by rightȬclicking the field with your denominator and sort ascending. While holding down the
“Ctrl” key, highlight all the records that have a value
of zero. From the “Options” button menu, choose
“Switch Selection” so that all of the records with nonȬ
zero values are highlighted. Now you should be able
to proceed with calculating values.
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Location Quotients
The location quotient is most frequently used in economic geography and locational analysis, but it
has much wider applicability. The location quotient (LQ) is an index for comparing an areaȇs share of
a particular activity with the areaȇs share of some basic or aggregate phenomenon. In other words, the
LQ is a measure of the relative significance of a phenomenon (e.g. burglaries) in a region (Newark)
compared with its significance in a larger (ȈbenchmarkȈ) region (New Jersey). Or, put another way,
LQ is a measure used to identify concentration within an area and is expressed as a ratio of the
proportional share of the subjects at the local level (census tract) to the ratio of the total area covered
(Philadelphia). Location quotients are calculated within the Attribute Table of a polygon feature class.
Location quotient is expressed as:

where xi represents the number of persons in group x (e.g., study group) in census tract i; ti represents
the total population of persons (e.g., general or poverty) in the particular census tract i; and X and T
represent the cityȬwide number of persons in group x and population t, respectively. The numerator
of Equation (3Ȭ1) is the percentage of the activity in area i, and the denominator is the percentage of
the base. A location quotient is thus the ratio of two percentages and is therefore dimensionless.
(NOTE: A common error occurs in ArcGIS when a calculation requires dividing by zero (0) for at
least one record in the attribute table. Check your data and calculate again using only the “selected”
records whose denominator will not be an attribute with the value of zero.)
If LQ>1

this indicates a relative concentration of the activity in area I, compared to the region as a
whole.

If LQ =1 the area has a share of the activity in accordance with its share of the base.
If LQ<1

the area has less of a share of the activity than is more generally, or regionally, found.

The formula for Location Quotients requires that something of interest (e.g., Index Crimes per
County) be divided by some other meaningful variable, such as “square miles”, “population”,
“number of sworn police officers”, etc.
Location Quotients are interpreted as “the likelihood of finding ‘something’ of interest in an area,
given the other attribute about that area.” In effect, the Location Quotient formula controls for the
denominator variable. So, a question might be: “What is the likelihood of index crimes occurring in
each county, given the number of people (i.e. population) who could commit a crime in that county?”
Results less than 1 are not very likely, and the likelihood increases as values increase above 1.
Location quotient values, once calculated, can be displayed as a choropleth map.
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ZOOM IN: Location Quotient Choropleth Maps22
Metraux, Caplan, Klugman and Hadley (2007) used location quotients (LQ) to assess the extent of
residential segregation among 15,246 people diagnosed with severe mental illness (SMI) and
receiving Medicaid in Philadelphia. Once location quotients were calculated in the Attributes Table of
the Census Tract Shapefile, corresponding choropleth maps were constructed using ArcGIS. The
figure below (left) shows areas of Philadelphia with elevated LQs for the study group based on using
the general population of adults as the denominator for both local and overall proportions.

Location quotient values for adults (ages 18Ȭ–64) living in households with incomes below the
poverty threshold, based on their proportional representation among the overall adult population are
presented in the figure above (middle). Census tracts with the highest LQs for the study group
contained disproportionate shares of poor adults, which suggested that poverty should be controlled
for. The figure above (right) shows LQs for the study group using “adults in poverty” as the
denominator (rather than the general population of adults)—in effect controlling for poverty. By
controlling for poverty, the number of tracts with substantial concentration (LQ > 2) was reduced and
the tracts with elevated LQs (i.e., high concentrations of SMI persons) were more scattered across
Philadelphia. They also included areas that did not have an elevated poverty LQ. This more
accurately depicted the concentrations and distribution of SMI persons throughout the city.
Results indicated that overall levels of residential segregation among persons with SMI were modest
at their most extreme, were not markedly different from a control group of Medicaid recipients
without any record of treatment for SMI, and were substantially reduced after taking poverty into
account. There were, however, localized areas in Philadelphia that showed distinct concentrations of
persons with psychiatric disability, suggesting there may be a subgroup that is more atȬrisk for living
in areas with elevated concentrations of persons with serious psychiatric disability.
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Editing Individual Values
Starting an Edit Session

From the “Editor” toolbar, click “Editor” button > Start Editing
You can only edit the contents
of one directory at a time in an
edit session, so you need to
identify the directory that
contains the table you wish to
edit. While this is the more careful way to proceed, it is also more
tedious.
You may get a message warning you that the layer’s attributes that
are about to be edited are in a different coordinate system than the
current map’s coordinate system. When editing attribute data, this
is less of an issue. However, when editing features of the layer, this
can—and most likely will—give you unexpected alignment or
accuracy problems. It is a good habit to always work with layers
that are properly projected.

Editing Attribute Data

Open your attributes table and, using the select elements
tool click on the cell in your table you wish to edit. When
you are finished, go to “stop editing” in the edit toolbar and
choose “Yes” to save your edits.

Finding & Replacing Values

From the shapefile’s attribute table, click the “Options”
button > Find & Replace
Use the “Find & Replace” function to systematically find
and replace values in a table. In order to replace values,
you must have started an edit session (from the “Edit”
toolbar > Editor > Start Editing).
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Measuring with Attribute Data

If you need more accurate measures of distance than you can get using the measure tool, you can use
the values in perimeter (polygons) and length (line) fields of the shapefile attribute tables. Select the
features of interest, then right click on the perimeter or length field and go to “Summary.” The “sum”
field will indicate the total distance. For example, if you need to know the total length of Broad and
Market Streets, go to “Select by Attributes” and select all line segments in the street centerline file
called “BROAD” or “MARKET.” Then open the attribute table associated with the street centerline
file, right click on the “length” column heading, and go to “Summary.” The “sum” should indicate
how long Broad and Market Streets are. NOTE: You may need to first calculate perimeter or length values.
See the section (below) “Calculating Area, Perimeter and Length”.

Measuring Distance with Networks

Euclidean is just one method of measuring distance, and a rather crude one at that. Using ESRI’s
Network Analyst Extension is another method. It lets you factor in travel times and traffic patterns,
among other considerations.

Calculating Area, Perimeter, and Length

From the shapefile’s attribute table, rightȬclick on column name where you want to calculate values >
Calculate Geometry
Usually there will be fields called “area”, “perimeter”, and “length” in a shapefile when you receive it
that indicates the measures of each map feature. If your shapefile is missing these fields or if you
have edited the shape and size of the map features, you will need to calculate them yourself. Area, for
example, can be especially helpful when you are trying to normalize values and create densities (i.e.
calculating persons per square mile).
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For this example, we will calculate “Area,” though the process is very similar for the other
calculations, as you’ll see. You must open the attribute table associated with your shapefile (right
click on the name in the table of contents and go to “Open Attribute Table”). From the options menu,
go to “Add Field.” Call your field “area,” choose “double” as the style, and click “OK.” Right click on
your new field and go to “Calculate Geometry.”

Select the geometric property you want to calculate
from the “Property” dropȬdown menu. Different
properties are available depending on the type of layer
youȇre using. To calculate Area, select “Area” from the
dropȬdown menu. To calculate Perimeter, select
“Perimeter” from the dropȬdown menu, etc. Click to
use either the coordinate system of the data source or
the coordinate system of the data frame. Select the
units of the output calculations.
Optionally, if you have selected records in the table, choose whether to apply the calculations to all
records or just the selected ones. Finally, click OK.

Tips (adapted or excerpted from ArcGIS Help files)
x

You can only calculate the area, length, or perimeter of features if the coordinate system being
used is projected.

x

Keep in mind that different projections have different spatial properties and distortions. If the
coordinate system of the data source and data frame are not the same, you may get a different
result if you calculate geometry using the data frameȇs coordinate system than when you
calculate using the data sourceȇs coordinate system.

x

If you are calculating into a text field, you can choose to add a units abbreviation to the
calculation. For instance, 47.5673 sq m is an example of the output of area calculated into a text
field with the units abbreviation.

x

To avoid seeing the warning message when you attempt to calculate values outside an edit
session, you can check the Donȇt warn me again box on the message. You can turn on the
warning message again from the Tables tab of the Tools > Options menu.

The Calculate Geometry dialog box respects the number of decimal places (three, by default)
specified on the General tab of the Editing Options dialog box. To change this setting, click the
Editor menu on the Editor toolbar and click Options. This setting is saved in the map document.
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Georectifying Images

Georeferencing allows you to convert a picture or scanned map image into a GIS map layer.
Essentially, the process assigns X and Y coordinates to points on your digital map image, shifting,
rotating, and scaling your map so that you can view it as a map layer along with your shapefiles.
Create a Raster Image: Scan your paper map, take a photograph, or use a computer graphic. The
higher the resolution, the better. ArcMap can handle pretty big files, and it can work with lots of file
types (.jpg, .tif, .bmp). If you have a choice, go with .tif.
Add a Map Image: Add your image to ArcMap just as you would a shapefile or table, using the
button or from the file menu, choose “add layer.” Depending upon the size of your image, a
dialogue box will ask you if you’d like to add pyramids. Click “OK.”
Don’t worry if you get a warning message that your image
lacks projection information. The name of your image
should now appear in the table of contents and be drawn
in the map view window. At this point, your image is in
“pixel space” since there is no coordinate information.

Add Reference Layers (shapefiles): Choose an existing shapefile that contains spatial information
that will help you georeference your paper map (choose more than one, if necessary). You need a
shapefile that covers the same extent as your paper map and
that contains several points that you can identify visually on
your paper map. In the table of contents, put your reference
layer(s) on top of your map image and highlight the
reference shapefile.
Right click and choose “zoom to layer.” From the view menu,
choose
toolbars
then
georeferencing.
From
the
georeferencing menu, choose “Fit to Display.” Now your
reference layer(s) should draw on top of your map image in
the view map window.
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Add Control Points

Click the “add control points” button. Create your first control point on your image by clicking once
on a point that you can also identify on your shapefile. Then click on the shapefile in the
corresponding spot. Double click to create a control point. You may find it easier to use the magnifier
window (from the window menu, choose “magnifier”). Create additional control points. After doing
this two or three times, your paper map should shift significantly to line up with the shapefile.
Continue to add control points as long as doing so improves the alignment.
View Links
Click on the “view links” button to view the coordinates of each of the control points you’ve created.
The “residuals” column indicates the amount of error.
You may improve the alignment of your image by
deleting the point(s) with the greatest error. Click on the
button to delete control points. If you have six or
more control points, you can perform a second order
transformation; if you have twelve or more control
points, you can perform a third order transformation.
Rectify Image
In order to permanently save the transformation, choose “rectify” from the georeferencing menu.
ArcMap will create a new image (rather than changing your original data). Check the ArcMap
Desktop Help if you want information about choosing a resampling type. You don’t have to rectify
your image. If you want to revert to your original (ungeoreferenced) image, from the georeferencing
menu, choose “reset transformation.”

Editing Existing Shapefiles

Editing shapefiles is tricky—and a bit dangerous—territory. If possible, use
the geoprocessing tools to make changes to your shapefiles rather than
using the editing tools described below. Also keep in mind that editing
shapefiles can change attribute values (such as area and perimeter) that
you may need to update.

Deleting and Modifying Features

From the “Editor” toolbar, click the “Edit” tool
In order to make changes to a shapefile, you must start an edit session. From
the Editor toolbar, choose “start editing.” If you have multiple shapefiles in
your map document that are from different subdirectories on your computer,
you will need to specify which directory will be part of the edit session (you
can only edit the files in a single folder at one time). From the Target drop
down menu in the Editor toolbar, indicate which map layer you wish to edit.
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Use the “Edit” tool to click on the feature (point,
line, polygon) you wish to edit (it should
become highlighted). By clicking and holding
down the mouse button, you can move your
map feature to a new location. To modify a line
or polygon feature, double click on it. Notice
that the vertices become visible and the Task
menu automatically brings up “Modify a
Feature.” You can reshape your feature by
putting your cursor over a vertex, clicking, and
dragging it. Click outside of the map feature to
complete. (ArcGIS will show the last created
vertex in red). You can add a vertex to a feature by right clicking on a green line and going to “insert
vertex” (a new vertex will be created where you right click). Click anywhere on the map to confirm
the edits. You can delete a vertex by placing your cursor over the vertex, rightȬclicking, and choosing
“Delete Vertex.”
To save edits, from the Editor menu on the Editor toolbar, choose “Stop Editing” and choose “yes” to
saving edits. Notice that you do not have a “save as” option. You may want to make a backup of your
original data before editing.

Advanced Edit Tools

There are several advanced editing tools. To access them, go to View > Toolbars > Advanced Editing.

Edit Tasks

The Task dropȬdown list on the Editor toolbar contains a set of editing tasks that affects how the
Sketch tool functions. The editing tasks are organized into four groups: Create Tasks, Modify Tasks,
Topology Tasks, and Other Tasks.
For example, to split features—to cut a polygon into two new
polygons—select the polygon you want to cut, choose that Cut
Polygon Features task, then use the Sketch tool to define the line
along which you want to cut the selected polygon.

Merging Features

In order to dissolve the
boundaries between two or more
polygon features, you must start an edit session. Using the edit
tool and the shift key, click on the features you wish to merge
(they should become highlighted), then from the Editor menu on
the Editor toolbar select “Merge.” You can also select map features
based on their attributes by opening the attribute table and
selecting the corresponding records.
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Intersecting Features

The Intersect command creates a new feature from the common areas or edges of any two selected
features of the same geometry type. For instance, you can create a new patrol area out of overlapping
patrol areas. The original features are maintained, and the new feature is created in the target layer
without attribute values (they can be entered manually).

Before
& After

The Intersect command is in the “Editor” drop down menu on the Editor Toolbar. You can create a
new feature from the intersection of features of different layers, but the layers must be of the same
geometry type (either line or polygon). Line features that you are trying to intersect must share a
common edge. Two lines that cross each other, such as in a X pattern, do not share a common edge.
To break this type of line intersection you must use the “Split” command on the Editor toolbar. The
Intersect command only works on two selected features. The Intersect Geoprocessing Tool creates
new features from the overlaps of all input layers or feature classes. You can also choose what
attributes from the input features will be transferred to the features of the output shapefile.
To intersect features, click the Edit tool on the Editor Toolbar. Click the features from whose
intersection you want to create a new feature. Click the Target layer dropȬdown arrow and click the
layer with the type of features you want the new feature to belong. Click the Editor menu and select
Intersect.

Digitizing Using the Merge Tool

From the “Editor” toolbar, click the “Editor” button > Merge
The tools in ArcMap for dissolving boundaries between features provide another approach to
digitizing. This may give you less control over the shape of new map features, but it provides an
easier way of creating new shapefiles that line up with existing shapefiles. In order to create
shapefiles using the dissolve tools, you need to have a shapefile that can serve as building blocks for
your new file. For example, you may want to create a map of health districts. If the districts are based
on census tracts, you can use a shapefile of census tracts to build your new district file. A census
block file may prove the most helpful. Census blocks are bounded by streets, so any new polygon
feature with streets as
borders can be created
by
dissolving
the
boundaries
between
census blocks. To start,
add a street centerline
layer and census block
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layer to ArcMap. To avoid making permanent changes to your census block file, create a new copy of
it (right click on it, go to “Data” and “Export Data”) and add it to your map. With the streets and
(new) block layers drawn, zoom into the area where you wish to create new features. Use the label
tool to identify street names (that’s why you need the street file; census block files don’t contain street
names). Using the Select Features tool, highlight the blocks that cover the area of your new feature.
You can select multiple features by holding down the shift key. You can also draw a box around the
area containing the individual features (this is faster).
To dissolve the boundaries between the blocks, start an edit session, then from the Editor menu
choose “merge.” Stop editing and save edits to finish. If your new shapefile only needs to include this
single map feature, you can right click on the block shapefile (with the new feature still selected), go
to Data and Export Data. Be sure that the Export drop down menu indicates that only selected
features will be included. Alternatively, you may need to repeat the process of dissolving boundaries
so that all census blocks become part of a new map feature.

Adding Other Graphics

ArcMap also has a set of tools on the Drawing toolbar used to draw graphics.
Objects drawn with the drawing tools are stored in the map document as graphics,
not as features in a feature class (and they have no attributes attached to them). To
access the Drawing toolbar, click “View”, “Toolbars,” and select “Draw.” From the
Drawing toolbar, click any of the drawing tools (as shown to the right) and draw graphics.

Creating New Shapefiles23

From ArcCatalog, rightȬclick the folder where the shapefile will be stored > New > Shapefile
Most of the time you will use shapefiles that someone else created. Using existing shapefiles saves
time and generally results in more accurate map layers. But if you need a line or polygon file that
does not exist—such as a boundary for your study area—you will need to create it yourself.
Digitizing is the process of drawing or tracing map features to create a new geographic file. ArcGIS
has some onȬscreen digitizing tools that allow you to create new shapefiles without additional
hardware or software.
From the “Create New Shapefile” dialog box, give your new
shapefile a name and indicate what type of features the shapefile
will have: point, line, or polygon. Use the Edit button to set the
projection. This shapefile is essentially just a shell since it contains
no information. But you need this before you can start to create new
map features.
Next, open ArcMap and add your
new shapefile, along with other
map layers that may serve as
references to help you draw your
new features. Start an edit session:
from the Editor menu in the Editor toolbar, choose “Start Edit
Session,” and indicate which directory contains the shapefile (shell)
you just created.
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Be sure that your new shapefile is listed as the
“Target” in the “Editor” toolbar and that
“Create New Features” is selected from the
“Task” menu. Choose a drawing tool. You
have nine choices:
Use the Sketch tool to create point features and digitize the vertices of line or polygon features. After
you finish the sketch, ArcMap adds the final segment, and the sketch turns into a feature.
The Arc tool helps you create a segment that is a parametric (true) curve. Instead of being made of
numerous vertices, a parametric curve has only two vertices as endpoints. You might use the Arc tool
to digitize a culȬdeȬsac, using an aerial photo image as a backdrop.
The Direction–Distance tool allows you to create a vertex using a distance from a known point plus
a direction from a known point to define a bearing line. For example, a pole might be located at a
specified distance from the corner of one building and at a defined angle from the corner of another
building.
The Distance–Distance tool lets you create a point or vertex at the intersection of two distances from
two other points.
The Endpoint Arc tool allows you to specify the start and endpoints of the curve, then define a radius
for the curve. This is particularly useful in sketching culȬdeȬsacs, where the beginning and ending
points of the arc, as well as the radius of the culȬdeȬsac, are known.
The Intersection tool creates a point or vertex at the place where two segments would intersect if
extended far enough.
The Midpoint tool lets you define the location of the next vertex by clicking two points; the new
vertex is placed at the midpoint of the line between these points. If you were creating a road feature
class from parcel data, you might use the Midpoint tool to create the vertices directly between the
parcels on opposing sides of the road.
The Tangent tool adds a segment that is tangential to the previously sketched segment. This tool is
practical when sketching rail lines in which the curves are nearly always tangential to the previous
segment. Note that the Tangent tool can only be used if you have already sketched a segment using
one of the other sketch construction tools.
The Trace tool helps you create segments that follow along
existing segments. Suppose you want to add a new road
casing feature that is offset 15 feet from the front of a parcel
subdivision. You could use the Trace tool to trace along the
existing line features instead of typing the angle and length of
each segment. Youȇll need to select the parcel features before
you can start tracing the road casing feature. The Trace tool
only follows selected features. Click to create a new vertex, click again to create another vertex, etc.
RightȬclick and click “Finish Sketch” to finish. In the example here, a new polygon feature was drawn
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that follows streets. To delete the newlyȬcreated feature, click on it using the Edit Tool to select it and
then hit the delete key on your keyboard. Hit Ctrl+Z to undo the last vertex. To save your new
feature, from the Editor menu choose “Stop Editing” and save edits.

Snapping to an Existing Feature

From the “Editor” toolbar, click the “Editor” button > Snapping (you must “Start Editing” first)
It is nearly impossible to draw features that match an existing layer just by
looking at it. Zooming in to the polygon shapefile created above shows
that there are gaps between the new shapefile and the street centerline that
was used as a guide. This looks sloppy and can impact the result of your
analyses.
You can avoid this problem by “snapping” your new lines to an existing
shapefile. From the Editor menu of the Editor toolbar, go to Start Editing
and indicate which directory contains the shapefile (shell) to which you
want to add map features. At the top of the “Snapping Environment”
options box, you can identify the layer(s) to which you want to snap your
new features. Try drawing your new features using different combinations
of layers and vertices and/or edges. If you use a street centerline file as
your guide, vertices will work well.
To create the most accurate line, move your cursor slowly over the
existing shapefile, clicking at each vertex to create a new vertex in
your shapefile. You can change the snapping “tolerance”—the
distance from the existing shapefile you can be and still snap to
it—from the Editor menu choose “Options,” and go to the
“General” tab. The map units reflect the units you identified in the
Data Frame properties (General tab).
Using the snapping tool, you should be able to create new features that line up with existing
shapefiles, even when you zoom in close. If you are not happy with your results, click on the map
feature with the Edit tool and hit Delete (you can do this even after saving edits to the shapefile, as
long as you start an Edit Session).

Adding Attribute Data to New Features

From ArcMap’s Table of Contents, rightȬclick layer > Properties > Open Attribute Table
After creating new features in a new shapefile (or after editing/adding features in an existing
shapefile), you can assign information to them in the Attributes table. Attribute tables of new
shapefiles with new features will have only three columns named FID, Shape, and ID. These are
automatically created by ArcMap. To add new fields so that you can enter additional information,
click the “Options” button in the Attributes table, then click “Add Field.” If you are unable to select
this option, go back to the Editor toolbar, click Stop Editing, and then try again to add a field (You
cannot add new fields during an edit session). Once the new field has (or many fields have) been
added, click Editor on the Editor toolbar, and then Start Editing. Be sure to save your edits! NOTE: In
order to enter data into the fields of an Attribute table, you must be in an edit session.
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Buffers

Buffers allow you to create temporary graphics or permanent
shapefiles around existing map features. You can create buffers
around any type of vector data (points, line, or polyons) and
around selected or all features in a map layer. The Buffer Wizard
is a custom tool that must be added to the ArcMap interface.
From the tools menu, go to “customize” and click on the
“commands” tab. From the “categories” list, click on “tools.” You
can then drag the Buffer Wizard to one of your active toolbars.
From the drop down menu in the Buffer Wizard, choose the map
layer you wish to buffer. If some of the features in your layers are
selected, you can choose to buffer only the highlighted features.
On the next screen, you choose how you want to create buffers. You
can make buffers based on a certain distance or based on an attribute
in your map layer (this would allow you to have larger and smaller
buffers around different features). If necessary, change the distance
units at the bottom of the screen. You can make multiple rings of a
certain distance.
On the final screen, you must decide what to do if the buffers
overlap: dissolve the intersecting lines or leave them? If the map
layer you are buffering contains polygons, you can specify whether
buffers should be drawn inside, outside, or both. Finally, specify
how ArcMap should save the layer. If you save it as a graphic, it will
be temporary. This is helpful if you are just playing to get the right
buffer since it can easily be deleted. Saving the buffers as a separate
shapefile is more permanent and deleting a shapefile involves more
work. To save the buffer as part of an existing layer, you must start
an edit session and make that layer editȬable.
Buffering can take ArcGIS a long time, especially if you choose to
dissolve the barriers within the buffers. However, if you do not dissolve
the barriers, your buffers may involve lots of separate polygons. If you
saved the buffers as a shapefile, there will be an attribute table with
records corresponding to the separate polygons making up the buffer. If
you choose to dissolve the barriers, there will be just one record (and just
one polygon). NOTE: A “Buffer” tool is also available: ArcToolbox > “Proximity” toolset > “Buffer” tool

ArcToolbox Window24

From ArcMap or ArcCatalog, click the “ArcToolbox” button
The ArcToolbox window is where you find, manage, and execute geoprocessing tools. Tools are (and
must be) stored in Toolboxes, which are sorted alphabetically. The exact number of tools and
toolboxes available depends on what extensions you have installed. You can also create your own
tools (with Python or ModelBuilder), organize them into new toolsets and toolboxes, and share them
with any ArcGIS user.
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The toolboxes you see in ArcToolbox are analogous to shortcuts in Windows Explorer or layers
within ArcMap. If you remove a toolbox from ArcToolbox, you are simply removing it from the list
and not actually deleting it on disk. BUT, if you delete a tool in a toolbox, the tool will be
permanently deleted from the disk.
ArcToolbox Window
Toolbox
Toolset
Tool

Docking and Undocking

Press the “Ctrl” key when dragging the ArcToolbox window
You can move the ArcToolbox window by clicking on the bar at the
top and dragging it. The window can be docked—like the Table of
Contents, or you can undock the window to have it float above the
application by pressing the <Ctrl> key when dragging.

Opening Tools

From the ArcToolbox window, doubleȬclick the tool

Search Tab

If you know, generally, the name of the tool you want to use or the
function you want to perform, but cannot remember where the tool is
located, use the “Search” tab. Type in the keyword(s) and click the “Search” button. Results will
appear in the box below. After finding the tool you want to use, click the “Locate” button to show
where it is in the tree view or doubleȬclick the tool to open its dialog box.

Model Builder

ModelBuilder is a tool that helps you build, manage and automate spatial models. A spatial model is
a set of one or more processes. A process includes input data, a spatial function (tool) that operates on
the input data, and output data. Processes can be connected so that the output of one process
becomes the input to another process.
A spatial model is represented in
ModelBuilder as a diagram that looks like
a flowchart. The spatial model does not
actually contain spatial data; it has
placeholders,
called
nodes,
which
represent the data that is processed and created when the model is run. The nodes are connected by
arrows that show the sequence of processing in the model. The actual data is managed and displayed
in ArcMap; ModelBuilder just gives processing instructions to ArcMap when the model is run.
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To build a new model, start by opening ArcMap and add one or more
existing data layers that will be used as input to the model you are about to
build. Open the ArcToolbox window by clicking the “Show/Hide
ArcToolbox Window” button.
RightȬclick inside the ArcToolbox
window > New Toolbox. Give the new
toolbox a meaningful name. RightȬ
click the new toolbox > New > Model.
The ModelBuilder window will open.
You can create your model there.

Detailed steps for using
ModelBuilder to build a
model are not discussed
here.
For
more
information refer to the
ArcGIS Desktop Help.

ModelBuilder Tips
x Do not use Model > Run to execute a model. Instead, use Model > Run Entire Model
x To save a model, use Model > Save
x To close a model, use Model > Close or just close the ModelBuilder window.
x To rename a model, rightȬclick on its name in the ArcToolbox > Rename
x To open a saved model for editing, rightȬclick on its name in ArcToolbox > Edit
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Spatial Data Processing Tools
Transforming Shapefiles

There are a number of different functions you can perform on map layers, either based on location or
attribute values that result in new map layers. In ArcGIS 9, they have been incorporated into an
expanded suite of ArcToolbox tools. You must define the projection for map layers before using any
of these functions. If you have selected a subset of features within a map layer, the functions will only
be performed on the selected features.
Examples of the tools described in this section are below:

Dissolve

Append

Clip

Intersect

Union

Merge
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Dissolve

ArcToolbox > Data Management Tools > Generalization >
“Dissolve” tool
The dissolve operation allows you to collapse the boundaries
between polygons if they share the same value on a
particular attribute. For example, you could create a
neighborhood map layer by assigning each blockgroup to a
neighborhood and then dissolving the boundaries.

In the “Dissolve” dialog box, you need to identify the
map layer whose features you wish to dissolve under
“Input Features.” If the layer is already added to
ArcMap, you can use the dropdown menu. Otherwise
you need to click on the folder icon to locate the
shapefile. ArcMap will create a new shapefile with a
default name by adding “_Dissolve” to the original
name. If you want to rename this or change the
location, click on the folder to the right of “Output
Feature Class.”
Next, choose the column the shapefile’s attribute table that contains the information you wish to use
for the dissolve. This must be an attribute for which multiple map features (polygons) have the exact
same value. The values can be numbers or text, although keep in mind that nominal and categorical
variables will work better than ratio variables. If polygons have the same value but are not
contiguous, they will still be dissolved into a “multipart feature.”

Append

From ArcToolbox > Data Management Tools > General >
“Append” tool
Appending allows you to incorporate two or more nonȬ
overlapping layers into a single map layer without changing
their map features. You can append point, line, and polygon
layers. Appending can save you time when it comes to
symbolizing features and can lead to more consistent
symbology. For example, you can append (i.e. merge) census
tract files from several counties so that when you display the
percent of homeowners, you do not have to repeat the
process of classifying your data for each county.
In the “Append” dialog box, under “Input Datasets,”
list all the map layers you wish to merge. You can use
the dropdown menu if you have already added the
map layers to ArcMap, but you will need to add them
one at a time.
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A new layer will not automatically be created, so you will need to specify an EXISTING layer in the
“Target Dataset” field. This will overwrite the existing layer, so be sure to make a backup copy if
necessary. If the columns in the attribute tables of all the input
features are identical, you can select “TEST” under “Scheme
Type.” Otherwise, you must choose “NO_TEST.”
The resulting shapefile will contain all of the map features in
the appended layers. If the column names were the same for
all of the layers (as they could be for census tract files from
different counties), there will be values for each record in each
column. Keep in mind that these merged shapefiles can grow
very large, particularly if you merge street centerline files.

Clip

From ArcToolbox > Analysis Tools > Extract > “Clip” tool
Clipping allows you to turn one shapefile into a cookieȬcutter
in order to cut out part of a larger shapefile. For example, you
might need to create a map layer of streets for the area within
a single police district but your street centerline file covers the
entire city. Using a street file that is clipped by the police
district boundaries will allow you to work with a smaller and
more manageable file that looks neater.
The “Clip” tool allows you to clip vector
shapefiles. In “Clip” dialog box, you
need to identify an input feature (the
layer to be clipped) and the clip
features (cookie cutter). Specify the
name and location of the new file in the
“Output Feature Class” field. You can
leave “XY Tolerance” blank, or at 0.
Changing it will allow slightly
mismatched map layers to be
considered “coincident.”
To clip raster grids you need to use a raster clipping tool. This can be found in
ArcToolbox under Data Management Tools > Raster > Raster Processing. You can
also find vector and raster clipping tools by searching for keyword “clip” in the Search tab of
ArcToolbox. DoubleȬclicking on the tool in the results area opens it directly.

Intersect

From ArcToolbox > Analysis Tools > Overlay > “Intersect” tool
Intersect allows you to fuse two overlapping layers together to create a new shapefile that includes
the attributes of both layers for the area in which the layers overlap. In effect, this combines the union
(described below) and clip operations. You can intersect two polygon layers or a line and polygon
layer.
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In the “Intersect” dialog box, select the Input Features. The default
name for the new shapefile will be the first input feature name
plus “_Intersect.” If you want to change this or the location of the
new file, click on the folder to the right of the “Output Feature
Class” field.
If you intersect a line and
polygon layers, the resulting shapefile will contain “polylines”
that act like lines. If you intersect polygon layers, the resulting
shapefile will contain polygons. Length, perimeter, and area
values will be inaccurate after you perform an intersection, so
if you need these be sure to recalculate them. Other attribute
values maybe deceptive, as well. In the example at the left,
census tracts were intersected with police districts. The result
was many sliver polygons resulting from slight differences in
their digital boundaries, not real differences in their actual boundaries. Note that three polygons have
been given the same total population based on the census tract data, two of which are sliver
polygons. Adjusting the cluster tolerance can help you avoid sliver polygons.

Union

From ArcToolbox > Analysis Tools > Overlay > “Union” tool
Union is similar to intersection in that it fuses the boundaries of
two layers together, but rather than clipping the resulting
shapefile to include only the area covered by both, it creates a
new shapefile that covers the combined extent of the layers.
From the “Union” dialog box, select the Input Features. The
default name for the new shapefile will be the first input
feature name plus “_Union.” If you want to change this or
the location of the new file, click on the folder to the right of
the “Output Feature Class” field. As with shapefiles created
through intersections, the shapefiles created by a union will
most likely have some attribute values that no longer make
sense. Be sure to recalculate length, perimeter, and area if
you need these variables.

Merge

From ArcToolbox > Data Management Tools > General > “Merge” tool
Merge is similar to “Dissolve”. However, while the Dissolve tool
combines features within the same shapefile based on a common
attribute, the Merge tool combines features from multiple
sources/shapefiles into a single, new, output shapefile. The features
must all be the same type (i.e. point, line, polygon). The “Merge” tool
keeps all of the input features as separate entities. The input features
do not have to be adjacent, overlap or distance between features is
allowed.
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From the “Merge” dialog box, select all of the input datasets that you want to combine together.
These can be point, line, or polygon feature classes; tables can also be merged. In the “Output
Dataset” text box, specify a name and location the new shapefile that will be created.

Create Random Points

From ArcToolbox > Data Management Tools > Feature Class > “Create Random Points” tool
This tool does just what it says—it creates a specified number of random points within a given area,
within polygons, or along line features of a shapefile. The placement of points is done according to
specialized algorithms that consider the geography of the extent where the points can lay. Remember,
“random” does not mean “mutually exclusive.” So, at least conceivably, two or more points can be
placed at the same location; this is rare, but the probability does exist. It is always a good habit to
review the placement of points after they are created to ensure that they will satisfy your needs.
NOTE: This tool is only available if the Spatial Analyst or 3D Analyst extension is installed.
The “Output Location” text box requires you to select an existing folder (i.e. directory) where the new
shapefile with random points will be created. The “Constraining Feature Class” or “Constraining
Extent” options are useful if you want to limit the possible locations of points to a specific study area
(i.e. extent) or within/along features of an existing shapefile. For example, researchers at Rutgers
University sought to measure the impact of surveillance cameras on crime within the cameras’
immediate areas. Their quasiȬexperimental design called for a comparison between areas
surrounding the surveillance cameras (i.e. cases) and areas elsewhere in the city (i.e. control areas).
The selection of control areas was done randomly using the “Create Random Points” tool. Since
surveillance cameras were only placed along streets, the permissible locations for control cameras to
be placed had to mimic this limitation. Therefore, a streets shapefile was used as the “Constraining
Feature Class” to ensure that random points could only be set along streets
in the city. NOTE: When you “constrain” points to features, ArcMap places the
specified number points to every unique feature. With a shapefile of streets, for
example, which tends to have many line segments, 10 points will be randomly
placed on every line segment if you specify
“10” as the value in the “Number of Points”
text box.
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Spatial Analyst Extension

The Spatial Analyst Extension is specifically intended for the processing of grids (raster data). You
will need the Spatial Analyst Extension and requisite toolbar to make density maps and work with
raster data. Accessing the extension requires up to 3 steps.

1. Install and Register the Spatial Analyst Extension

Whether you have a trial version or a full license of ArcGIS, you will need to install and register the
Spatial Analyst Extension before creating density raster maps. To do this, go to Start > Programs >
ArcGIS > Desktop Administrator. Select the “Register…Extensions” folder and then click the
“Register Now” button. When the Registration Wizard appears, select the radio button next to “I
have already registered the software and need
to register additional ArcGIS extensions”.
Continue through the following registration
screens, entering your user information as
requested.

For trial version users (screens and
options may differ slightly for fully
licensed users): When you get to the
“Evaluate ArcGIS Extensions” screen, click the radio button next to “I would like to evaluate one or
more of the following extensions for a limited period of time.” Then select the Spatial Analyst
Extension by checking the box. Click the “Next” Button to continue with the registration. If you
registered using the internet (recommended) you should receive a confirmation in the “Automatic
Registration” screen as to what programs and extensions
have been “Successfully registered and authorized”. Click
the “Finish” button and then exit out of ArcGIS Desktop
Administrator.

2. Activate the Spatial Analyst Extension

Once extensions are installed and registered, you need to
activate them. Open ArcMap and click Tools > Extensions.
Check “Spatial Analyst” and then click the “Close” button.

3. Display the Spatial Analyst Toolbar
The Spatial Analyst Toolbar looks like this:
If the toolbar is not already visible, go to View > Toolbars, then select “Spatial Analyst”.
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Density Raster Mapping

From “Spatial Analyst” toolbar, click “Spatial Analyst” button > Density
You will need the Spatial Analyst Extension installed, registered and activated, and the toolbar
visible, to make a density map (see above). In the “Density” dialog box, select the input shapefile to
calculate density from. The input can be a point or polyline feature class. Point density calculates the
density of point features around each output raster cell.
Conceptually, a neighborhood is defined around each raster cell
center, and the number of points that fall within the
neighborhood is totaled and divided by the area of the
neighborhood. Line density calculates the density of linear
features in the neighborhood of each output raster cell, and is
calculated in units of length per unit of the area.
The Population field is the quantity that is to be used in the
calculation of, or that is spread across the landscape to create, a
continuous surface. Use ȈNone” if no item or special value will
be used and each feature will be counted once.
Simple vs. Kernel Density Calculations: If the selected density
type is ȈSimpleȈ, and if the input is points, Density calculates the
density of point features around each output raster cell. If the
input is lines, Density calculates the length of the portion of each line that falls within the circle and
then multiplies it by the Population field value. If the selected density type is ȈKernelȈ, conceptually,
a smooth curved surface is fitted over each point feature. The surface value is highest at the location
of the point, and diminishes with increasing distance from the point, reaching zero at search radius
distance from the point.
The ȈSearch RadiusȈ determines the distance to search for points in order to catch for a density value
for each cell in the output raster. If the option is set to save the output in the same coordinate system
is the first input (on General tab of the Options dialog), the units for the search radius will be the
same as the map units of the first input. If the option is set to save the output in the same coordinate
system is the active data frame, the units for the search radius will be the same as the map units of the
data frame.
“Area units” determines the units in which the density values will be
calculated. The output density values are calculated as magnitude
per Area Unit. If the map units are known (i.e., projected), then Area
Units can be Square Miles, Square Kilometers, Acres, Hectares,
Square Yards, Square Inches, Square Meters, Square Centimeters, or
Square Millimeters. The ȈOutput cell sizeȈ refers to the size of
individual cells in the output raster. Cell size determines how coarse
or smooth the patterns will appear. The smaller the cell size, the
smoother the density surface will be. However, very small cells also
require considerably more processing time and computer storage space. The size of the search radius
will determine how generalized the density patterns will appear. A smaller search radius will show
more local variation, while a larger search radius will show broader patterns in the data.
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Name the new density map in the ȈOutput rasterȈ box. If you leave the default, <temporary>, the
output raster will be temporarily written to your working directory. If you do not specify a path for
the output raster, but type a name, it will be permanently written to your working directory. You can
also type the path to a location on disk, or use the browse button to navigate to a location to place the
output raster. To make a temporary result permanent, rightȬclick on the output in the Table of
Contents and click “Make Permanent.” If you do not make temporary rasters permanent, they will
not be available the next time you open your project (even if you save your project).

Possible Error Calculating Density of Geocoded Points

You might receive an error message when attempting to calculate the
density of points that were geocoded with a match rate below 100%. The
cause of the error is likely that there are “unmatched” addresses that
appear in the shapefile’s attribute table. Because the addresses are unmatched, there are no respective
points on the map. This presents a problem to ArcGIS when it cannot find these points to include in
the density calculation. To resolve this quickly, you must create a new shapefile with only the
“matched” or “tied” records, thereby removing the “unmatched” records from the shapefile and its
attribute table. Or, if you want a more inclusive density map with all of the original records, you
must clean the data and geocode it properly.
To remove unmatched records from an existing shapefile: In the
Attributes table, there is a column called ȈStatusȈ that notes
whether each record was Matched (M), Tied (T), or Unmatched
(U) during the geocoding process. Select all of the “M” and “T”
records and then export these selected data to create a new
shapefile (i.e. without unmatched records). Perform a density
calculation using this new shapefile as the “Input data”.

Density Map Symbology

From ArcMap’s Table of Contents, rightȬclick the layer > Properties > “Symbology” tab
Symbolizing raster (i.e. density) maps differs slightly from vector maps.
By default, density map symbology is displayed as Equal Interval. You
may get a message that says “Unique histogram does not exist. Do you
want to compute unique values?” Click “Yes”. In the “Layer Properties”
dialog box, under the ȈSymbologyȈ tab, click the “Classify” button under
the “Classified” scheme (on the left). Standard Deviation (SD)
is a good option for showing variation in raster values. The
map on the left in the example below shows a “Stretched”
classification scheme, whereby each cell is shaded from white
to black according to its density value. In this map, darker
colored
cells
represent a higher
density of gang
member residences.
The map on the right shows the same cells classified into
four groups—according to SD breaks. White colored cells
have values below the mean cell value; cells colored light
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grey have values between the mean and +1 standard deviation (SD); cells colored dark grey have
values between +1 SD and +2 SD; cells colored black have values greater than +2 SD. In other words,
the black colored cells have values in the top five percent of the distribution (remember the 68Ȭ95Ȭ99.7
rule from statistics?).

Symbolizing Raster Density Maps with
Multiple Layers

It can be difficult to symbolize a density raster map in a way
that makes another map layer below it easily visible. For
example, you could make the top raster map partially
transparent to see through it to the layer below, as shown in
the figure to the right. However, this can be confusing to the
map reader and it tends to print to paper much worse than it
appears on a computer screen.

Transparency works best with color raster maps, but should be used cautiously and sparingly, and
only after careful consideration has been given to the map’s intended purpose and the medium by
which the final map will be delivered (i.e. computer screen or printed document). Colors and
transparency are not appropriate for blackȬandȬwhite publishing (e.g. journal articles) or for
documents that will likely be copied and distributed widely (e.g. policy briefs).
Converting raster maps to vector features (such as
polygons) provides additional symbology options,
particularly in grayscale. For example, the figure to the left
communicates the same information as the color map
(above), but does so in grayscale and with the “Social
Services Density” layer converted from raster to polygonal
features. This allows for the crosshatching that symbolizes
the “Highest” density areas. Layering these raster and
vector maps permits a clearer visual analysis of the spatial
overlap of parolee residences and social services: While
parolees may live on any piece of land in Newark (with the
exclusion of Newark International Airport or the seaport), a
higher concentration of parolees live in the shaded grey
areas on the map; a higher concentration of social services
are located within the black outlines and crosshatched areas
on the map.
Before converting a raster map to polygonal features, you should
symbolize it using the “Classified” schema. The “Classified” schema
groups raster cells based on their respective values, and then symbolizes
them accordingly. For example, the raster map to the right is classified
into four categories: All raster cells whose numerical values are above +2
Standard Deviations (SD) are symbolized with the color Black. All raster
cells whose numerical values are between +1 SD and +2 SD are
symbolized with the Medium Grey color; between the Mean and +1 SD is
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Light Grey; less than the Mean is White. Each raster cell retains its original value; it is merely
(temporarily) symbolized according to a four category classification schema. You can then convert
the similarly grouped contiguous cells into polygonal features. First, however, you must perminantly
change the values of the cells to specify to which group they belong. For example, all cells whose
original values are above +2 SD (symbolized by the color Black) will get a new value of “4”; all cells
whose original values are between +1 SD and +2 SD will get a new value of “3”; and so on. This task
is done using the “Reclassify” operation in the Spatial Analyst Extension.

Reclassify Raster Values

On the “Spatial Analyst” toolbar, click Spatial Analyst > Reclassify
A raster map is a grid of equallyȬsized cells covering the entire study area. Each cell has only one
value associated with it. The Reclassify operation changes the values. This can be used to generalize
or create new categories of data, or to create discrete categories from continuous data (such as density
values).

In the “Input Raster” field of the “Reclassify” dialog box, select the raster map whose values you
want to perminately change. (“Reclassify” actually creates a new raster layer, so the original raster
map and data will not be altered). Notice how the “Old values” are grouped into the same
classification schema that the map is symbolized in. By default, the “New values” are ordered
numerically (e.g. from 1 to 4). In the example above, all cells with old values between zero (0) and
1.8308733713175455eȬ007 will get a new value of 1, and so
on. Manually enter new values for each category or keep
the defaults. New values can be of the numerical or string
type. Choose a name and location to save the “Output
raster” and then click the “OK” button. A new raster map
will be created: In this example, each cell will have a value
of either 1, 2, 3 or 4.
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The Attribute table of the new (Reclassified) raster
map shows that 13,712 cells now have the value of
“1”, 1,267 cells have the value “2”, and so on.
Groups of contiguous cells with the same values can
now be converted into polygonal features using the
“Convert” tool.

Raster/Vector Conversions (Convert Tool)

In the “Spatial Analyst” toolbar, click Spatial Analyst > Convert > Raster to Features.

In the “Raster to Features” window, select your reclassified raster map as the “Input raster”. You will
only have one option in the “Field” drop down menu—“Value”: the value of each cell will be saved
in the Attribute table of the new vector shapefile. The “Output geometry type” should be “Polygon.”
Generalizing lines is helpful for getting rid of the stairȬstepped look that features can have when
converted from square raster cells. In the “Output features” text box, give a name and location for the
polygon shapefile that will be created.
The newly created polygon shapefile will have a unique
feature for each group of contiguous cells that was in the input
raster map. Each polygonal feature will also have a respective
record in the shapefile’s Attribute table. The attribute of each
polygon will be the value of the cells that once comprised the
area within it. As shown in the figure to the left, the selected
polygon was once a contiguous group of cells with the value
“4”.
These polygonal features
can be symbolized like any
other vector shapefile by
rightȬclicking on the layer
in the TOC > click “Properties” > select the “Symbology” tab. You
can also calculate area/perimeter, perform spatial joins, etc.
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Raster Analysis/Output Extent

From the “Spatial Analyst” toolbar, click “Spatial Analyst”
button > Options > “Extent” tab
At the outset of a raster data analysis, you might want to
define a particular study area, referred to in ArcGIS as the
analysis ȈextentȈ. Or, you might notice that some of the
areas on the density raster map that you created seem to
have the hotspots cut off, as exemplified in the black
circles to the right. This occurs when the extent of the
density calculation is limited to only the perimeter (i.e.
extent) of the points that you are calculating the density
of. Imagine this phenomenon as ArcGIS framing the
output density raster map to only the smallest square box
that includes all of the input points. Instead, you want the
extent to be the same as the data frame or the other
shapefile layers that you are working with (such as a city
outline).
In the “Extent” tab of the “Options” dialog box, the
default setting is likely to be “Intersection of Inputs.” In
the “Analysis extent” drop down menu, select an
appropriate extent to meet your needs. If you want to use
the same extent as another shapefile, add that shapefile
layer to the Table of Contents in ArcMap first, then adjust
the Analysis Extent: The drop down menu will provide an
option for “Same as layer…”. Click OK. Future density calculations will use
this newly set extent.

Clipping Raster Maps

From ArcToolbox > Data Management Tools > Raster > Raster
Processing > “Clip” tool
To clip density maps exactly to the outline of features from another
shapefile, such as a city outline, you need to use a raster clipping tool. In
the “Clip” dialog box, the “Input Raster” will be your density map. The
“Output Extent” will be an existing raster or vector shapefile which will
be used as the clip extent (like a cookie cutter). If you
want to clip the raster based on the polygon features
within the shapefile, check the box next to “Use Input
Features for Clipping Geometry (optional)”. NOTE:
Raster Dataset file names cannot be more than 13
characters.

“NoData” Raster Cell Values

Every raster cell has a value assigned to it. Values can be either positive or negative, integer, or
floating point. Cells can also have a “NoData” value to represent the absence of data. NoData means
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that not enough information is known about a cell to assign it a value; or, that the cells are in areas
that a user intentionally does not want to display (or wants to exclude from raster calculations).
NoData and 0 are not the same; 0 is a valid value. If NoData exists in any of the input raster datasets
the computation of output values can be affected in one of three ways: NoData is returned for the cell
location no matter what; NoData is ignored and a value is computed using any available values; or a
value is estimated for the cell location and NoData cannot be returned.
By default, NoData values are displayed transparent in a raster map. To change the symbology from
ArcMap, rightȬclick on the raster layer > Properties > “Symbology” tab > click the “Display NoData
as” dropȬdown arrow > select a color > click “OK” button.

Raster Calculator

From the “Spatial Analyst” toolbar, click “Spatial Analyst” > Raster Calculator
The “Raster Calculator” operation in the Spatial Analyst Extension creates a new grid on which the
value of each cell is computed by applying map algebra and/or logical functions to the value of the
cell on one or more existing grids. Essentially, it produces a new composite map. Consider, for
example, the three raster (grid) layers shown to the left. In each layer, cell values range from 0 to 3. If
Raster Calculator were to be used to add each cellȇs
values on these three grids, the result would be a
composite raster map with cell values (potentially)
ranging from 0 to 9.

The “Raster Calculator” dialog box provides for building algebraȬlike expressions that will produce
new maps. Variables (in the form of grid layers and/or numbers) and functions are inserted into the
expression box either by typing, by doubleȬ
clicking on the layer names in the “Layers”
section, or by using the buttons. Once an
expression has been fully specified, click the
“Evaluate” button to generate a new grid.
Logical
Logical expressions prove to be either true or
Expressions
false for any given cell. These results are
Operators
stored in the form of a new grid on which
every cell is either set to 1 (for true) or 0 (for
false).
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Neighborhood Statistics23

From the “Spatial Analyst” toolbar, click “Spatial Analyst” > Neighborhood Statistics
This creates a new grid in which each
cellȇs value is computed by applying a
specified statistical function to the values
of an existing grid that are associated with a
neighborhood of surrounding cells.
This
neighborhood may be in any of a variety of
shapes and/or sizes.
From the “Neighborhood Statistics” dialog
box, specify your input raster data. This function will not work with
vector data. In the “Field” text box, select the field from the input data
you wish to use in the calculation. In the “Statistic type” text box, select
the statistic with which the input values are to be summarized. There
are 10 statistics available, each producing a different type of result (see
below). In the “Neighborhood” dropȬdown menu, specify the shape of
the neighborhoods. Then in the “Neighborhood Settings” section, specify the size (the number of cells
or map units) of the neighborhoods. The neighborhood dictates the shape of the area used to obtain a
value for the cell being processed. There are four available shapes: rectangle, circle, annulus, wedge.

Neighborhood Statistics Operations
x The sum statistic computes a new value for each cell by adding the existing value of that cell to
those of its adjacent neighbors.
x The mean statistic computes a new value for each cell by averaging the existing value of that cell
with those of its adjacent neighbors.
x The median statistic selects whichever of the values in the immediate vicinity of that cell comes
closest to being equal to or just greater than those of half the others.
x The maximum statistic computes a new value for each cell by selecting the greatest value to
occur within its immediate vicinity.
x The minimum statistic computes a new value for each cell by selecting the lowest value to occur
within its immediate vicinity.
x The majority statistic computes a new value for each cell by selecting whichever value occurs
most frequently within its immediate vicinity. If two or more values tie for that distinction, a
value of NoData is assigned.
x The minority statistic computes a new value for each cell by selecting whichever value occurs
least frequently within its immediate vicinity. If two or more values tie for that distinction, a
value of NoData (black) is assigned.
x The range statistic computes a new value for each cell by subtracting the lowest value from the
greatest value to occur within its immediate vicinity.
x The standard deviation statistic computes a new value for each cell by calculating the mean of
the squared differences between the average of all values in its immediate vicinity and each
original value.
x The variety statistic computes a new value for each cell by determining how many different
conditions occur within its immediate vicinity.
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Spatial Analyst’s Distance Operations26

You can perform distance analysis of raster data using two
main methods: Euclidean distance and cost distance.
Euclidean Distance measures straightȬline distance (from cell
center to cell center) from each cell to the closest source; the
source identifies the objects of interest, such as roads or a
school. Cost Weighted Distance tool equates distance as a cost
factor—the cost to travel through any given cell. For example,
it may be shorter to (illegally) travel through a private
property to get to a destination, but it is less risky to walk
around it.

Straight Line Distance

From the “Spatial Analyst” toolbar, click “Spatial Analyst” > Distance > Straight
Line
The straight line distance option creates a new grid in which each cell’s value
indicates its horizontal distance between the center of that cell and the center of
the nearest of a designated set of cells on an existing grid. The units of distance
are map units associated with the coordinate system of the source layer.

Allocation

From the “Spatial Analyst” toolbar, click “Spatial Analyst” > Distance > Allocation
The allocation option creates a new grid in which each cell is set to
the value of the nearest of a designated set of source cells on an
existing grid (or source features of points, lines, or polygons). Here,
every cell has been set to the value of the nearest DrugȬFree School
Zone. This “zoning” of the landscape that is generated by this
operation is variously referred to as “proximal zones”, “Voronoi
regions”, WignerȬSeitz cells”, “post office areas”, and “Thiessen
Polygons“. The “Create allocation” checkbox on the “Straight Line”
distance dialog box does the same thing.
Allocation works with raster
or vector data. Every cell or
feature about which each
allocated zone will be
created must have a unique
value. ArcGIS produces one
zone per unique value per
cell/feature. Raster cells
always have only one
attribute (though not always unique). The field (i.e. column)
used by ArcGIS to create zones around point, line, or polygon
features must be specified manually: In the layer’s attribute
table, right click the column heading > Properties > check the
box next to “Use Field as Primary Display Field”.
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Cost Weighted

From the “Spatial Analyst” toolbar, click “Spatial Analyst” > Distance > Cost Weighted
The cost weighted distance operation is similar to the “straight line”
option in that nearness is defined in terms of distances that are measured
horizontally from the center of each cell to the center of the nearest
source cell. However, with the Cost Weighted option, those distances are
not measured in units such as feet or meters. Instead, they are measured
in units such as minutes, gallons of fuel, or risk of apprehension. These
are not merely units of physical separation but units of cost that
accumulate as a consequence of motion across a physical environment.

Shortest Path

From the “Spatial Analyst” toolbar, click “Spatial Analyst” > Distance > Shortest Path
The Shortest Path operation generates a shapefile of one or more lines that trace the path(s) of
minimum cost between designated “source” and “destination” areas. The operation is closely related
to the cost weighted distance operation and, in fact, relies on that operation to calculate the costs to be
minimized. The destination layer can either be a shapefile of point, line, or polygon features (in which
case the destination feature(s) should be selected), or a raster grid (in which case a destination zone
should either be selected or just set to any value other than NoData).
One final item to be specified in
the “Shortest Path” dialog box is
the “Path Type” that can be set
to any of three choices: Best
Single, For Each Zone, or For
Each Cell. The “Best Single”
option traces the shortest path
[Best Single]
[For Each Zone]
[For Each Cell]
from the source to whichever
destination cell is closest. The “For Each Zone” option traces the shortest path from the source to
whichever cell is closest within each of the zones of cells that comprise a destination. The “For Each
Cell” option traces the shortest path from the source to every cell that is part of the destination.

ArcScene 3D Modeling

What most distinguishes ArcScene from the other ArcGIS applications is its ability to place layers in a
threeȬdimensional setting. ArcScene may be used to explore the relationship of two variables in one
map by adding a thirdȬdimension. For example, you might extrude polygons of New Jersey counties
to heights that represent the number of fullȬtime municipal
police officers, while symbolizing the same polygons with
a gradient of colors that represent arrest rates. You might
hypothesize that counties with the most police officers will
also have the highest arrest rates. The third dimension
allows you to explore the relationship between two
separate attributes of a single polygon shapefile. Although
this 3D map can be exported as a 2D image, this technique
is recommended here more for exploration of GIS data
layers and variables, not as a final map.
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File > Add Data ȬorȬ Click the “Add Data” button
You can also click and drag shapefiles right into ArcScene: From ArcMap, click on the layer in the
Table of Contents and hold down > drag to the Table of Contents on ArcScene and let go.

Removing Layers from ArcScene

From the Table of Contents, rightȬclick the layer > Remove

Layer Properties

From the Table of Contents, rightȬclick the layer > Properties
The “Layer Properties” dialog box offers more
options—compared to the number offered in
ArcCatalog or ArcMap. Most tabs/options should
already be familiar to you from working in ArcMap
(if not, see earlier chapters of this document).
Under the “Extrusion” tab you can turn point
features into vertical lines, lines into walls, and
polygons into blocks.
Under the “Base Heights” tab, you can set the height
of continuous surfaces based on a constant value or
by referencing one or more attributes so the height
can vary from feature to feature. For example, the
figure to the right is a raster map whose cells are
elevated based on the density of Social Services the
city. Darker shades of blue represent areas with
higher concentrations of people living at or below
poverty. This map is one way to communicate that
the poverty population in the city does not tend to
live near where the highest concentrations of social
services are located.
The “Navigate” tool on the “Tools” toolbar
lets you rotate the display about two axes:
one running left to right through the cartographic
plane, and the other running perpendicular to it.
NOTE: Refer to ArcGIS Desktop Help for more
information about using ArcScene.
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Nearest Neighbor Analysis

From ArcToolbox > Spatial Statistics Tools > Analyzing Patterns > “Average Nearest Neighbor” tool
The Average Nearest Neighbor tool in ArcGIS is used to perform a Nearest Neighbor (NN) analysis.
The NN analysis is a test of spatial randomness and works by calculating the distance from each
point in a collection to its nearest neighboring point. For polygon or line features, the NN analysis
measures the distance between each feature’s centroid and its nearest neighbor’s centroid location.
These distances are then compared to the expected mean NN distance for a random distribution of
points. If the average distance is less than the average for a hypothetical random distribution, then
the features being analyzed are considered clustered. If the average distance is greater than a
hypothetical random distribution, the features are considered dispersed. The equation in ArcGIS
used to calculate the average NN value, Z score, and pȬvalue are based on the assumption that the
points being measured are free to locate anywhere within the study area (i.e. all points are located
independently of one another).

Graphic obtained from ArcGIS Desktop Help

The Average Nearest Neighbor tool was
used to determine whether the highȬrisk
(polygon/vector) cells in the Period 1
Risk Terrain (left) were statistically
significantly clustered. Results suggest
that there is less than one percent
likelihood that the clustered pattern of
high risk cells could be the result of
random chance (Observed/Expected
Mean Distance = 0.63; Z Score = Ȭ14.33
standard deviations; Critical Value = Ȭ
2.58; p<0.01). Although this is quite
evident upon visual inspection, the
pattern is statistically significant. Other
patterns may not be so obvious.
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The pin map to the left is another example
of how Nearest Neighbor analysis can be
used. It shows incident locations of DWI
arrests during 2008. If motor vehicle stops
that result in DWI arrests cluster in certain
areas of the city, then police patrols and
interventions such as sobriety checkpoints
are warranted, and can be more easily and
efficiently targeted to the highȬrisk
locations. Results of a NN analysis
suggest that the distribution of DWI arrest
locations is significantly clustered (z
score= Ȭ10.31; R=0.33; p<0.05; Mean NN
Dist.=348.07;
Expected
Mean
NN
Dist.=1065.90). A density map or standard
deviation ellipse might be used to show
how and where DWI arrests are
concentrated in particular areas.

From the “Average Nearest Neighbor” dialog box, select your input shapefile for which the average
NN index will be calculated. This is typically a point shapefile, but can be line or polygon shapefile as
well. You will need to specify how distances between features should be calculated. “Euclidean
Distance” is the default and most commonly used. It measures straightȬline distances (as the crow
flies).
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ZOOM IN: Parole Officer Caseloads27
Mellow, Schlager, and Caplan (2008) randomly selected parole officersȇ caseloads from the Newark,
NJ region to investigate their distribution and overlap. Minimum convex polygons (MCP) were used
to show the smallest perimeter within which each of these caseloads was distributed (see below, left).
Further analysis revealed that caseloads were inefficiently distributed and had a high degree of
overlap: Parole officer (PO) Aȇs case load of 24 parolees
represented just 4% of the total study sample, but was
distributed to a perimeter of 13.49 miles and covered an area
of 11 square miles, or 45% of the total Newark study area; PO
Bȇs case load of 24 parolees represented just 4% of the total
study sample, but was distributed to a perimeter of 14.85
miles and covered an area of 13 square miles, or 53% of the
total study area; PO Cȇs case load of 18 parolees represented
just 3% of the total study sample, but was distributed to a
perimeter of 15.41 miles and covered an area of 13 square
miles, or 49% of the total study area.
Related to overlap, clustering of PO caseloads should be a
logistical concern for parole agencies because the geographic
distribution of parolees within a caseload is an enabling
factor for parole officers to serve as efficient and effective case managers and supervisors. Therefore,
it was hypothesized by Mellow et al. that the residential locations of parolees within the same
caseload would be spatially clustered together in certain parts of Newark. This was not the case.
Nearest Neighbor analyses validated the researchers’ conclusion that regardless of caseload size,
parolees within a given caseload were randomly dispersed throughout Newark without any regard
to geographic clustering. A random distribution suggested no forethought on the part of the parole
agency to assign caseloads based on the geographic location of parolee residences. On average,
parolees on the same case load resided ten times farther apart from each other than the “natural”
geographic distribution of all parolee residences within Newark.
Through a hypotheticȬdeductive process that utilized GIS, Mellow et al. concluded that a revised
system of caseload allocation based on the natural distribution of parolee residences could save time,
money and resources for parole officers and their agencies. The study also provided empirical
evidence that GIS is an instrumental tool for use in the parole system.

Standard Deviation Ellipses28

From ArcToolbox > Spatial Statistics Tools > Measuring Geographic Distributions > “Directional
Distribution” tool
A Standard Deviation Ellipse (SDE) can be used to
measure central tendency of a set of points, lines or
polygons. A SDE identifies dispersion as the
standard deviation of the distance of each feature
location from the mean center, as well as the
direction of that dispersion. The mean center, or
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central location, refers to the arithmetic mean of all feature locations (centroids are used in the case of
line or polygon features). The ellipse is referred to as the standard deviation ellipse because the
method calculates the standard deviation of the x coordinates and y coordinates of each feature from
the mean center to define the outer bounds of a smoothed ellipse polygon, which is displayed as a
map feature. The attribute values for a SDE include two standard distances (long and short axes), the
orientation of the ellipse, and the case field, if specified.
The “Directional Distribution” tool in ArcGIS creates SDEs. In the “Directional Distribution” dialog
box, select a shapefile to be the “Input Feature Class.” This should contain the set of points, lines, or
polygons for which the SDE will be calculated. In the “Output
Ellipse Feature Class” field, choose a name and location for the
new polygon shapefile that will contain the output ellipse feature.
Choose the size of the output ellipse in the “Ellipse Size” drop
down menu. The default is 1 standard deviation (SD); available
options are 1, 2, or 3. With features normally distributed around
the mean center, one SD will cover approximately 68 percent of all
input feature centroids. Two
SDs will cover approximately
95 percent of all feature
centroids. Three SDs will cover
approximately 99 percent of all
feature centroids.

The optional “Weight Field” permits the weighting of locations
according to their relative importance; it is based on a value in the input
shapefile’s attribute table. The resulting ellipse is termed a weighted
SDE. The optional “Case Field” can be used to group features for
separate directional distribution calculations. The Case Field can be of
numeric, date, or string type. Once all parameters have been set, click the
OK button.

Hot Spot Analysis (GetisȬOrd Gi*)29

From ArcToolbox > Spatial Statistics Tools > Mapping Clusters > “Hot Spot Analysis” tool
Your choice of symbolgy and classification schemes might imply areas that some people would call
“hot spots” upon visual inspection alone. However, this terminology should be used cautiously. The
(often) arbitrary choice of colors and classification ranges, or the classification method (e.g. Equal
Interval, Natural Breaks, Standard Deviation) could substantially change a map’s appearance. For
this reason, a “hot spot” defined upon visual inspection is much different than a “statistically
significant hot spot”. To be statistically significant, a feature must have a high value and be
surrounded by other features with high values. Similarly, cold spots consist of features with low
values surrounded by other features with low values. This pattern must occur beyond random
chance.
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The “Hot Spot Analysis” tool in ArcGIS calculates the GetisȬOrd Gi* statistic (Z score) for each feature
in a dataset. The larger the statistically significant positive Z score is, the more intense the clustering
of high values (hot spot). The smaller the statistically significant negative Z score is, the more intense
the clustering of low values (cold spot).

The default selections in the “Hot Spot Analysis” dialog box are recommended. The Input Feature
Class (shapefile) must have an analysis field (Input Field). The tool assesses whether high or low
values (e.g. the number of crimes per polygon; number of victims for each point) cluster spatially.
The field containing those values is your analysis field. Prepare this field in the shapefile’s attribute
table before using the “Hot Spot Analysis” tool. Output from this tool may look similar to the
example map below—where red colored cells represent statistically significant hot spots of “high
risk” locations, and blue colored cells represent statistically significant cold spots of “low risk”
locations.
How you construct the analysis field determines the
types of questions that can be asked. For example, if you
divide the number of burglaries by the number of
houses in a city, and then run the Hot Spot Analysis tool
on this ratio, you are no longer asking ȈWhere are there
a lot of burglaries?Ȉ. Instead, you are asking ȈWhere are
there unexpectedly high numbers of burglaries, given
the number of houses?Ȉ By creating a rate or ratio prior
to analysis, you can control for certain relationships and
possibly identify unexpected hot or cold spots.
NOTE: ArcGIS Desktop Help presents “3 things to consider
when undertaking any hot spot analysis”. You should review
this help section by searching for keywords “How hot spot
analysis works” > click to view the first topic found.
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Additional Spatial Analysis Software
CrimeStat

FREE | Available at: http://www.icpsr.umich.edu/CRIMESTAT
CrimeStat is a WindowsȬbased spatial statistics program for the analysis of crime incident locations
(point patterns). The program inputs incident locations in .dbf, .shp, ASCII or ODBCȬcompliant
formats using either spherical or projected coordinates. It can then calculate various spatial statistics
and write graphical objects in shapefile format. CrimeStat is a popular tool for researchers, police
departments and other public safety practitioners.

GeoDa

FREE | Available at: http://geodacenter.asu.edu/
GeoDa is a freestanding software application that does not require a specific GIS system. It consists of
an interactive environment that combines maps with statistical graphics, using the technology of
dynamically linked windows. GeoDa is often used to analyze aggregated crime data (area patterns);
but it also has a spatial regression package included that allows for the modeling of correlates or
determinants of crime. According to the GeoDa website, general features include:
Data Input and Output

Mapping

x

x

read and write shape files; copy graphs
and maps to clipboard; save maps and
graphs to bitmap file

Spatial Data Manipulation

x

create point shape files from text files;
centroids for polygons; Thiessen polygons
from points; contiguity based spatial
weights for polygons; distance based
spatial weights for points and polygons

Visualization and Queries

x

graphs, maps and table; linking and
brushing of all maps and graphs,
multiway linking of table; spatial selection
on maps; query selection in table

quantile and standard deviational maps;
outlier maps: box map and percentile
map; rate mapping and smoothing: excess
risk map, Empirical Bayes smoothing,
spatial smoothing; map movie

EDA

x

histogram; box plot; scatter plot; full
dynamic linking and brushing

Spatial Statistics

x

Moranȇs I; Moran scatterplot: univariate,
bivariate, EB corrected; LISA local Moran:
univariate, bivariate, EB corrected

For a detailed, but introductory, discussion of the functionality of CrimeStat and GeoDa, see pages
43Ȭ63 of Eck, J. E., Chainey, S. Cameron, J. G., Leitner, M., & Wilson, R. E. (2005). Mapping crime:
Understanding hot spots. Washington, D.C.: National Institute of Justice. Available at
http://www.ncjrs.gov/pdffiles1/nij/209393.pdf
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SchoolCop

FREE | Available at: http://www.schoolcopsoftware.com
The School Crime Operations Package (School COP) is a
FREE software application for entering, analyzing, and
mapping incidents that occur in and around schools. School
COP can include incident data from a single school or
several schools (for example, schools in a district). Target
users include school security staff, school police
departments, school resource officers, and school
administrative staff.
Schools can enter their own codes for describing attributes of incidents (e.g. incident type, severity,
status, special circumstances codes) and attributes of persons involved in incidents (e.g. actions taken
and special characteristics codes). These codes are used when new incidents are entered in the
system. School COP also includes a flexible search capability. Searches can be made for incidents
containing any specific value (e.g. all incidents that occurred in the cafeteria) or combination of
values (e.g. all incidents that occurred in a specific month that involves a suspension of a student).
School COP can produce maps showing the location of incidents within school buildings or on school
grounds and it can produce an assortment of graphs, including bar graphs and pie charts. It also
includes a variety of preȬformatted tabular reports, including reports that summarize a specific
incident or set of incidents and that aggregate incidents by month or school.

SPACE (Spatial Predictive Analysis of Crime Extension) by Bair Software
FREE | Available at: http://www.bairsoftware.com/space/

SPACE is an extension for ESRI’s ArcGIS application that provides tools optimized for crime analysis
and for analyzing and predicting spatial information. Its functionality is similar to what used to be
known as CASE, but it works with newer versions of ArcGIS.

x
x
x

Link points
Directional distribution
Spider diagram

x
x
x

Minimum convex polygon
Nearest neighbor

x
x

Study area
Buffer

Sequencing

Geospatial Modeling Environment (GME)

FREE | Available at: http://www.spatialecology.com/gme
GME incorporates most of the functionality of its predecessor, HawthsTools, and has many
improvements to facilitate analyses and modeling of spatial data. Whether you need to quickly place
random points on a map or test statistical models, the tools in GME are very useful.

More Options

The International Association of Crime Analysts (IACA) maintains a comprehensive list of analysis
software that can be useful to a variety of public safety practitioners: www.iaca.net/Software.asp
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125

ENDNOTES
Adapted from: http://law.justia.com/us/cfr/title41/41Ȭ3.1.1.2.13.8.175.6.8.html
Stoe, D. A. (2003). Using Geographic Information Systems To Map Crime Victim Services: A Guide for State
Victims of Crime Act Administrators and Victim Service Providers. U.S. Department of Justice: Washington,
DC.
3 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
4 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
5 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
6 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
7 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
8 Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
9 Ideas and lists presented in this section are not exhaustive. Products were listed in no particular order and
inclusion or exclusion of a particular GIS software or company does not suggest an endorsement (or lack
thereof) of that software or product.
10 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
11 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
12 Adapted from: Chainey, S. & Ratcliffe, J. (2005). GIS and Crime Mapping. Wiley: West Sussex, England
13 From:
http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?id=1430&pid=1427&topicname=How_and_when_to_u
se_attribute_tables
14 Adapted from: Ormsby, E., Napoleon, E., Burke, R., Groess, C., & Feaster, L. (2001). Getting to know ArcGIS
Desktop (2nd ed.). Redlands, CA: ESRI.
15 This section was adapted from content provided by: Ahmet Rahmi Kirkpinar, Graduate Student (2009),
Rutgers University, School of Criminal Justice.
16 Parts of this section were excerpted or adapted from Mapping Crime: Understanding Hot Spots (2005) by Eck,
Chainey, Cameron, Leitner, & Wilson. Available at http://www.ncjrs.gov/pdffiles1/nij/209393.pdf
17 This section was inspired by work produced by Jerry Ratcliffe and some of its content was adapted or
excerpted from http://www.jratcliffe.net/
18 This section was inspired by work produced by Jerry Ratcliffe and some of its content was adapted or
excerpted from http://www.jratcliffe.net/
19 Adapted from: http://www.fgdc.gov/metadata
20 This section was adapted from and inspired in part by the COPS Publication entitled Geocoding in Law
Enforcement [Final Report] (2000). Available at
www.cops.usdoj.gov/html/cd_rom/tech_docs/pubs/GeocodinginLawEnforcementFinalReport.pdf
21 Ratcliffe, J. H. (2004). Geocoding crime and a first estimate of a minimum acceptable hit rate. International
Journal of Geographical Information Science, 18, 61Ȭ72.
22 Metraux, S., Caplan, J. M., Klugman, D., & Hadley, T. R. (2007). Assessing Residential Segregation Among
Medicaid Recipients with Psychiatric Disability in Philadelphia. Journal of Community Psychology, 35(2), p.
239Ȭ255.
23 This section were adapted or excerpted from ArcGIS Desktop Help files.
24 This section were adapted or excerpted from ArcGIS Desktop Help files.
25 Some of the content of this section was adapted or excerpted from work produced by Dana Tomlin.
26 Some of the content of this section was adapted or excerpted from work produced by Dana Tomlin.
27 Mellow, J., Schlager, M. D., & Caplan, J. M. (2008). Using GIS to evaluate postȬrelease prisoner services in
Newark, New Jersey. Journal of Criminal Justice, 36(5).
28 This section was adapted or excerpted directly from ArcGIS Desktop Help files.
29 This section was adapted or excerpted directly from ArcGIS Desktop Help files.
1
2

